Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed 11.04 (with updates/ubuntu extras installed).

I am using a Dell Dimension 3000, and it is apparently not capable of running Unity.

There was no flickering during the install, but once I rebooted and logged in, it was so bad that everything on the screen was unreadable. Clicking on a menu will cause it to open, but it flickers so as to be unreadable. If you hover over the options, they will be visible for a moment, but it will them continue flickering.

If I immediately open Firefox upon login and touch nothing else (no menus, panels, or other windows), then I am able to use Firefox without the flickering, but the panels look fragmented and corrupted.

Here are a couple screenshots, which I hope have turned out okay (since as soon as I take the screenshot everything will begin flickering :P).

http://imgur.com/a/NBi0h

Note that in this second image that the 'Take screenshot' window is actually no longer open--the image just sticks to the screen anyway.

My graphics card:

00:02.0 VGA compatible controller: Intel Corporation 82865G Integrated Graphics Controller (rev 02)

Things I have tried:

  • As soon as I saved the second screenshot, my whole machine froze up. After absolutely no response to anything after ~10 minutes, I unplugged the machine (shudder) and started it up again. Thankfully, Firefox saved my post, and I was able to submit it.

  • This flickering happens in Ubuntu Classic as well ,and menus flicker.

  • Adding the phrase "i915.modeset=0" immediately before "quiet splash" did stop the flickering. However, it also changed my Princeton monitor's resolution to 640x460. Should I follow the instructions here?

Note: my monitor is marked as "Unknown" in the Monitor Settings window. There aren't any other resolutions available in the dropdown.

I have succeeded in making the change persistent. I will let you know how fixing the resolution goes.

Edit4: The instructions didn't work. Here's the terminal output:

jacob@hawaiian-punch:~$ xrandr
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 640 x 480, current 640 x 480, maximum 640 x 480
default connected 640x480+0+0 0mm x 0mm
   640x480         0.0* 
  1280x1024_60.00 (0xf9)  109.0MHz
        h: width  1280 start 1368 end 1496 total 1712 skew    0 clock   63.7KHz
        v: height 1024 start 1027 end 1034 total 1063           clock   59.9Hz
jacob@hawaiian-punch:~$ cvt 1280 1024
# 1280x1024 59.89 Hz (CVT 1.31M4) hsync: 63.67 kHz; pclk: 109.00 MHz
Modeline "1280x1024_60.00"  109.00  1280 1368 1496 1712  1024 1027 1034 1063 -hsync +vsync
jacob@hawaiian-punch:~$ xrandr --newmode "1280x1024_60.00"  109.00  1280 1368 1496 1712  1024 1027 1034 1063 -hsync +vsync
xrandr: Failed to get size of gamma for output default
X Error of failed request:  BadName (named color or font does not exist)
  Major opcode of failed request:  150 (RANDR)
  Minor opcode of failed request:  16 (RRCreateMode)
  Serial number of failed request:  19
  Current serial number in output stream:  19
jacob@hawaiian-punch:~$ 

Just tried

jacob@hawaiian-punch:~$ xrandr --rmmode "1280x1024_60.00"
xrandr: Failed to get size of gamma for output default

Tried a lower resolution, that did not work either

jacob@hawaiian-punch:~$ xrandr
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 640 x 480, current 640 x 480, maximum 640 x 480
default connected 640x480+0+0 0mm x 0mm
   640x480         0.0* 
  1280x1024_60.00 (0x10d)  109.0MHz
        h: width  1280 start 1368 end 1496 total 1712 skew    0 clock   63.7KHz
        v: height 1024 start 1027 end 1034 total 1063           clock   59.9Hz
  1024x768_60.00 (0x110)   63.5MHz
        h: width  1024 start 1072 end 1176 total 1328 skew    0 clock   47.8KHz
        v: height  768 start  771 end  775 total  798           clock   59.9Hz
jacob@hawaiian-punch:~$ cvt 1024 768
# 1024x768 59.92 Hz (CVT 0.79M3) hsync: 47.82 kHz; pclk: 63.50 MHz
Modeline "1024x768_60.00"   63.50  1024 1072 1176 1328  768 771 775 798 -hsync +vsync
jacob@hawaiian-punch:~$ xrandr --newmode "1024x768_60.00"   63.50  1024 1072 1176 1328  768 771 775 798 -hsync +vsync
xrandr: Failed to get size of gamma for output default
X Error of failed request:  BadName (named color or font does not exist)
  Major opcode of failed request:  150 (RANDR)
  Minor opcode of failed request:  16 (RRCreateMode)
  Serial number of failed request:  19
  Current serial number in output stream:  19
jacob@hawaiian-punch:~$ 

I found a workaround.

I undid the change to GRUB, and installed Unity 2d. There is no flickering of any kind in Unity 2d, and the resolution is just right. However, feel free to ask me anything else if someone would like to know more about the bug.

share|improve this question
    
Please can you edit your question with the following answers: Suggest change your session to ubuntu classic (bottom of the screen on logon page). Do you have flickering menus? What is your graphics card? lspci | grep VGA –  fossfreedom Apr 28 '11 at 19:59
    
Excellent - I'll amend my answer to show you how to make it persistent. Yes, please try those instructions - edit your question with any findings. –  fossfreedom Apr 28 '11 at 21:25
    
ok I think there is an issue with the X server - try a slightly lower resolution - cvt 1024x768 OR try removing the 1280x1024_60.00 mode i.e. xrandr --rmmode "1280x1024_60.00" before trying your xrandr --newmode command. –  fossfreedom Apr 28 '11 at 22:04
    
ok - run xrandr again - you should just see the 640x480 available. Retry adding 1024x768 and/or 1280x1024_60 –  fossfreedom Apr 28 '11 at 22:16
    
That's strange - your xrandr now has the lower resolution - can you choose this new resolution in the Monitors window? –  fossfreedom Apr 28 '11 at 22:31
show 3 more comments

2 Answers

OK - that is an old graphics card which will not support Unity. Dont worry though, you can try unity by installing Unity-2d through the Software Center.

More of a problem though is the flickering with ubuntu classic.

This is a worth a try -

Reboot, immediately after booting press shift to display your grub. press e to edit the config of that kernel line. Find the line ending 'quiet splash'. Edit that line so that is reads "i915.modeset=0 quiet splash" and press ctrl+x to boot.

i.e. add the phrase "i915.modeset=0" immediately before "quiet splash"

To make this persistent (i.e. after each reboot) then do the following:

In a terminal type

sudo nano /etc/default/grub

find the line

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

change it to

GRUB_CMDLINE_LINUX_DEFAULT="i915.modeset=0 quiet splash"

Type CTRL O to write the file Type CTRL X to exit

Then type

sudo update-grub
share|improve this answer
add comment

If you're running ubuntu 11.04 and have a 82855G, the only solution at the moment is to run the GUI in classic mode.

If you're running kubuntu, hit start (K) -> Computer -> System Preferences -> Desktop Effects and disable them.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.