Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am unable to run the Update Manager. When I start it, I get the following pop-up box: Not all updates can be installed

    Run a partial upgrade, to install as many updates as possible.

    This can be caused by:
    * A previous upgrade which didn't complete
    * Problems with some installed software
    * Unofficial software packages not provided by Ubuntu
    * Normal changes of a pre-release version of Ubuntu

I have the option to Partial Upgrade and Close. I have tried Partial Update and it often fails. I have tried

robert@mythbuntu-pc:~$ sudo dpkg --configure -a
[sudo] password for robert: 
dpkg: dependency problems prevent configuration of python-gi:
 libglib2.0-0 (2.36.0-1ubuntu2) breaks python-gi (<< 3.7.2) and is installed.
  Version of python-gi to be configured is 3.2.2-1~precise.
dpkg: error processing python-gi (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libimobiledevice3:
 libimobiledevice3 depends on libtasn1-3 (>= 2.14-0); however:
  Version of libtasn1-3 on system is 2.10-1ubuntu1.1.
dpkg: error processing libimobiledevice3 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libtasn1-3-dev:
 libtasn1-3-dev depends on libtasn1-3 (= 2.14-2); however:
  Version of libtasn1-3 on system is 2.10-1ubuntu1.1.
dpkg: error processing libtasn1-3-dev (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libimobiledevice-utils:
 libimobiledevice-utils depends on libimobiledevice3 (>= 1.1.4); however:
  Package libimobiledevice3 is not configured yet.
dpkg: error processing libimobiledevice-utils (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libtasn1-3-bin:
 libtasn1-3-bin depends on libtasn1-3 (>= 2.14-0); however:
  Version of libtasn1-3 on system is 2.10-1ubuntu1.1.
dpkg: error processing libtasn1-3-bin (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgnutls26:
 libgnutls26 depends on libtasn1-3 (>= 2.14-0); however:
  Version of libtasn1-3 on system is 2.10-1ubuntu1.1.
dpkg: error processing libgnutls26 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libimobiledevice-dev:
 libimobiledevice-dev depends on libimobiledevice3 (= 1.1.4-1ubuntu6.2); however:
  Package libimobiledevice3 is not configured yet.
 libimobiledevice-dev depends on libplist-dev; however:
  Package libplist-dev is not installed.
 libimobiledevice-dev depends on libtasn1-3-dev; however:
  Package libtasn1-3-dev is not configured yet.
dpkg: error processing libimobiledevice-dev (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgnutls-dev:
 libgnutls-dev depends on libgnutls26 (= 2.12.23-1ubuntu1.1); however:
  Package libgnutls26 is not configured yet.
 libgnutls-dev depends on libgnutls-openssl27 (= 2.12.23-1ubuntu1.1); however:
  Package libgnutls-openssl27 is not installed.
 libgnutls-dev depends on libgcrypt11-dev (>= 1.4.0); however:
  Package libgcrypt11-dev is not installed.
 libgnutls-dev depends on libtasn1-3-dev (>= 2.14); however:
  Package libtasn1-3-dev is not configured yet.
dpkg: error processing libgnutls-dev (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libglib2.0-dev:
 libglib2.0-dev depends on libglib2.0-bin (= 2.36.0-1ubuntu2); however:
  Version of libglib2.0-bin on system is 2.32.3-0ubuntu1.
 libglib2.0-dev depends on libpcre3-dev (>= 1:8.31); however:
  Package libpcre3-dev is not installed.
 libglib2.0-dev depends on pkg-config (>= 0.16.0); however:
  Package pkg-config is not installed.
dpkg: error processing libglib2.0-dev (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgnutlsxx27:
 libgnutlsxx27 depends on libgnutls26 (= 2.12.23-1ubuntu1.1); however:
  Package libgnutls26 is not configured yet.
dpkg: error processing libgnutlsxx27 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of glib-networking:
 glib-networking depends on libgnutls26 (>= 2.12.6.1-0); however:
  Package libgnutls26 is not configured yet.
 libglib2.0-0 (2.36.0-1ubuntu2) breaks glib-networking (<< 2.33.12) and is installed.
  Version of glib-networking to be configured is 2.32.1-1ubuntu2.
dpkg: error processing glib-networking (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 python-gi
 libimobiledevice3
 libtasn1-3-dev
 libimobiledevice-utils
 libtasn1-3-bin
 libgnutls26
 libimobiledevice-dev
 libgnutls-dev
 libglib2.0-dev
 libgnutlsxx27
 glib-networking
share|improve this question
    
Can you edit your question and add sudo apt-get check? –  Braiam Nov 13 '13 at 19:25
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.