Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I press the X button in Banshee's title bar, it hides, but the music continues playing. However, from time to time I need to quit Banshee completely. How can I do that? (pressing "close" from the menu bar doesn't help)

I know I could go for running killall banshee but that's not an elegant solution. Any other ideas? Is it even possible?

EDIT: After first few answers I noticed I must underline, I do not want to stop the music playback, I do not want to hide Banshee's window. What I want is to quit Banshee totally, in order f.e. to start JACK audio server (and for example restart Banshee).

share|improve this question
3  
I reworded my answer a bit to make it more clear. Because of the Sound Menu specification, you need to pause Banshee, then press 'close' -- which is why everyone is telling you to press pause. :) –  michaelms Apr 28 '11 at 22:43
2  
What a curious design decision. Perhaps progressive and innovative, but to leave out the option of properly quitting the program from the menubar is.. perplexing. I elected to deinstall banshee entirely and use a different program. –  user21893 Jul 19 '11 at 22:47
add comment

5 Answers

up vote 25 down vote accepted

This behavior -- which came about as a result of this bug report -- is a design decision based on the Ubuntu Sound Menu specification. To quote from the spec:

A compliant player should also keep playing if you close its window while it is playing; exit if you close its window while it is not playing...

If you have Banshee's sound menu integration turned on, pressing the 'x' won't quit the program while music is playing. To quit Banshee, you must first pause the music.

share|improve this answer
1  
I do know that! It's cool it hides instead of closing, but in some cases I need to quit the application totally. –  Rafał Cieślak Apr 28 '11 at 21:24
    
Re-read the last line of my answer (I'll make it bold so it's more clear). You can't quit Banshee while music is playing, so first you need to pause the music, then press the 'x'. –  michaelms Apr 28 '11 at 22:32
1  
That's it! I missed the fact the playback must be paused first. Great thanks, that solved my problem entirely :) –  Rafał Cieślak Apr 29 '11 at 18:18
2  
I think that there should still be an option to quit. Ctrl-W and the close-button (x) close the window, but IMHO, the quit menu item and Ctrl-Q shortcut should remain... –  Simon Jul 15 '11 at 5:38
1  
@Simon, I agree completely. I think it's confusing to have the same button/menu-item behave differently in different situations (music playing vs music paused). –  michaelms Jul 15 '11 at 13:15
show 1 more comment

See the little sound icon on your top right in the panel? Click on it and hit pause ;)

share|improve this answer
    
I do not want to pause music playback. I need to restart Banshee, because I have switched the sound server and the audio is stuck. Or I may need to quit the whole application to start the JACK audio server. Pausing the playback is not enough, I need to quit the application. –  Rafał Cieślak Apr 28 '11 at 21:27
    
Then you might as well assign a shortcut to killall ;) –  kovshenin Apr 29 '11 at 6:55
1  
I might. But that's not the reccomended way to close applications, isn't it? –  Rafał Cieślak Apr 29 '11 at 18:15
add comment

You can Quit Banshee by : Menubar > Media > Quit ;)

share|improve this answer
    
or you hit Ctrl-Q with Banshee focused/active :-) –  Christoph Apr 28 '11 at 19:37
1  
It doesn't help. It also just hides Banshee, but the program is still running. @Cristoph: this shortcut does not seem to work at all - no reaction. –  Rafał Cieślak Apr 28 '11 at 21:25
    
I'm fairly sure that Media > Quit (and the Ctrl-Q shortcut) do not exist in Ubuntu Natty with the Sound Menu extension active (as it is by default in Natty). This is a result of this commit: git.gnome.org/browse/banshee/commit/?id=bd1e65 –  michaelms Apr 28 '11 at 22:39
add comment

Note - you need to pause whatever is playing first otherwise all of the following methods will only close the window but Banshee will remain running in the sound indicator.


Click Media -> Close (Media -> Quit for Ubuntu < 11.04):

banshee close

or

press Ctrl+W

or

press Alt+M+C (Alt+M+Q for Ubuntu < 11.04)

or

right click on the launcher item and click 'Quit':

banshee quit launcher

share|improve this answer
    
Thanks to you too for the shortcuts (usefull!) and screenshot :D The point I missed was to pause the music first. –  Rafał Cieślak Apr 29 '11 at 18:20
add comment

You can't normally close banshee because Ubuntu Team has added a plug-in that integrates Banshee with the Unity desktop. You have to disable that plug-in in the "Preferences" menu to have an "Exit" option (Or CTRL+Q).

1.- Go to Edit > Preferences

2.- Go to the "Plug-ins" tab and disable the "Sound Menu Integration" plug-in.

3.- To REALLY quit Banshee, press CTRL+Q or Go to Multimedia >Exit

Hope it helps.

P.S. I don't like this kind of changes in Ubuntu, think that they should let the applications like they're released. With these constant and radical changes, Canonical is losing points against another distributions.

share|improve this answer
add comment

protected by Community Nov 28 '11 at 22:05

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.