Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried turning the shadows off with CCSM, but it does not work ;/

System info:

Ubuntu 11.04 NN x64 desktop, HP ProBook 4520s, Unity

share|improve this question

5 Answers 5

up vote 15 down vote accepted

I think you have to choose a theme other than Ambiance or Radiance, because those override compiz's shadow settings.

If you really want to use the Ambiance borders without shadows:

  1. Create a copy of Ambiance: cp -R /usr/share/themes/Ambiance ~/.themes
  2. open ~/.themes/Ambiance/metacity-1/metacity-theme-1.xml and remove all of the <shadow> tags.
  3. Open up appearance preferences and select your new, duplicate "Ambiance" theme.
  4. Disable shadows in CCSM
share|improve this answer
    
It's working! ;D Thank you very much! –  daqwid2727 Apr 28 '11 at 20:02
  • Install CompizConfig Settings Manager

    sudo apt-get install compizconfig-settings-manager

  • Launch it by searching from the dash in Unity, or Preferences > CompizConfig Settings Manager in Ubuntu Classic.
  • Navigate to the Window Decoration tab.enter image description here

  • Slide the Shadow Opacity to 0.enter image description here

share|improve this answer
1  
Hi, just given this a try. The radius or any other setting there seems to have no effect at all on shadows behind windows and menus. Turning off Window Decorations works, but it also removes all title bars and borders from windows (such as where the close, minimise and max buttons sit). It also removes the top bar. –  nLinked Apr 25 '11 at 10:35
    
@nLinked try the solution given for this question - how-can-i-remove-shadows-of-the-windows-in-unity –  avi Apr 28 '11 at 19:53
    
@Alan thx for the edit! –  avi May 3 '11 at 0:09
    
With the help of all these replies and the one below, I've managed to get it to work! Thanks so much! Here are my final instructions that worked in full for me: CompizConfigSettingsManager > Effects > Window Decoration > Shadow radius and shadow to 0. Then: sudo nautilus /usr/share/themes/Ambiance/metacity-1 Then: Make new copy of metacity-theme-1.xml called metacity-theme-1.xml.originalwithshadows Then:Edit metacity-theme-1.xml Remove all lines beginning with: <shadow...>, Save the file, Right-click desktop > Change desktop background, Themes tab, Ensure Ambiance is selected as theme –  nLinked May 3 '11 at 22:09

You can keep Ambiance as a theme, actually, or remove the shadows without editing the .xml files. You just have to open gconf-editor, via the terminal or Alt+F2, and then go to apps > metacity > general and uncheck "compositing manager". An additional advantage of this, if you've decided you like transparency in the terminal, is that, however many windows you have opened, the transparency is relative, not to the other windows (which can be confusing), but to the underlying desktop background.

share|improve this answer

The setting is not controlled by Compiz; they are part of the ambiance theme. Here is what I did to tame the shadows. Open a terminal and complete the following:

cd /usr/share/themes/Ambiance/metacity-1 sudo nano metacity-theme-1.xml

Find the line (use cntl+w) that says:

shadow radius=”45.0″ opacity=”0.75″color=”#abde4f” x_offset=”1″ y_offset=”4″

Change the radius to a value you can deal with… I chose 10.

You may also want to move this theme to your local .themes folder.

share|improve this answer

Using emerald is probably easiest.

share|improve this answer
2  
Can you explain how to do that? –  Eric Carvalho Mar 12 '13 at 18:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.