Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I previously had ubuntu 10.10 installed and upgraded to 11.04. However, desktop is same 10.10 (gnome) as despite the upgrade. How can I disable the Gnome and activate Unity instead?

share|improve this question
    
I've been giving 11.04 a test run this evening. I was pleasantly surprised to see that it's just good old GNOME that I've come to know and love! –  boehj Apr 28 '11 at 19:26
3  
Unity won't run if you don't have the right drivers, you might need to run 'additional drivers', then reboot and choose "ubuntu" from the log in screen. –  Jorge Castro Apr 28 '11 at 19:32
    
@Jorge Castro i clicked additional drivers, but nothing happened. there is no a window or another thing. –  burak Apr 28 '11 at 20:02
    
what is your graphics card? - type lspci | grep VGA in a terminal –  fossfreedom Apr 28 '11 at 20:14
    
@fossfredoom NVIDIA GT 240M CUDA 1 GB –  burak Apr 28 '11 at 20:20
show 3 more comments

4 Answers

up vote 5 down vote accepted

You should be able to activate the NVIDIA Driver in the Additional Drivers Window available when you login as Ubuntu Classic and navigate to System > Administrator > Additional Drivers

enter image description here

share|improve this answer
add comment

If you are not seeing any available drivers, check your software sources and make sure that the main, universe, multiverse and restricted repos are enabled.

Then, if you are comfortable in the terminal:

  • sudo apt-get install nvidia-current nvidia-settings

If you are more comfortable with synaptic/software center, you can open either one and search for the nvidia drivers, then install them (the packages name are nvidia-current and nvidia-settings).

share|improve this answer
add comment

Log out and then you will see the GDM, click on the drop down menu and select Ubuntu Unity

share|improve this answer
2  
There is no Ubuntu unity.There are Recovery console, Ubuntu, Ubuntu classic, Ubuntu classic(no effect), Ubuntu(safe mode), User definition session. I selected Ubuntu. –  burak Apr 28 '11 at 20:06
add comment

Unity is a plugin for Compiz Fusion. It works well with Gnome, actually I don't think it works with anything rather than Gnome (someone might want to follow up on this).

To enable Unity, you have to enable the plugin in your Compiz settings. I'd suggest an app called CCSM (CompizConfig Settings Manager) -- a visual interface to Compiz settings. You can get it from the Software Center. Find Unity in the list and enable the plugin.

Update: What if the plugin is already enabled?

Okay what I'm gonna suggest is dangerous, but worked for me. Remember the command ccsm, you might have to use that from the terminal to launch the manager again. Create a shortcut to your gnome terminal on your desktop (gnome-terminal). Go to the Compiz settings, go to Preferences and reset everything to defaults.

You might experience some display problems at this point, if your desktop gets unresponsive press Ctrl+Alt+1, login and type sudo service gdm restart, you might end up with a bare desktop without a single menu (I did). Run the terminal, run ccsm and enable the Unity plugin, it'll ask you about some conflicts, ask Compiz to resolve them and disable all plugins conflicting with Unity.

Worked for me at least. Let me know how it goes ;) and good luck!

share|improve this answer
    
i installed CompizConfig Settings Manager, and Unity is active(have tick). but the result is still same. –  burak Apr 28 '11 at 19:27
    
@burak I edited my answer to include a sort of hack I used to get this running, let me know if it works for you. –  kovshenin Apr 28 '11 at 19:32
    
@kovshenin i tried all, but it is not still working. –  burak Apr 28 '11 at 19:52
    
@burak, sorry then, I'm out of ideas ;) –  kovshenin Apr 28 '11 at 19:55
    
@kovshenin when i restart, there is no unity 2d(i saw on internet). there are Recovery console, Ubuntu, Ubuntu classic, Ubuntu classic(no effect), Ubuntu(safe mode), User definition session. maybe the problem is here –  burak Apr 28 '11 at 19:57
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.