Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After I start wvdial, I get the following lines

$sudo wvidal

 WvDial: Internet dialer version 1.61
    Initializing modem.
    Sending: ATZ
    OK
    Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
    ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
    OK
    Modem initialized.
    Sending: ATDT#777
    Waiting for carrier.
    ATDT#777
    CONNECT 3100000
    Carrier detected.  Waiting for prompt.
    ~[7f]}#@!}!}!} }8}"}&} } } } }#}$@#}%}&[7f]},H8}'}"}(}"F_~
    PPP negotiation detected.
    Starting pppd at Wed Nov 13 07:16:38 2013
    Pid of pppd: 12638
    Using interface ppp0
    pppd: `�9[08]X�9[08]
    pppd: `�9[08]X�9[08]
    pppd: `�9[08]X�9[08]
    pppd: `�9[08]X�9[08]
    local  IP address 115.242.214.172
    pppd: `�9[08]X�9[08]
    remote IP address 220.224.141.145
    pppd: `�9[08]X�9[08]
    primary   DNS address 220.226.6.104
    pppd: `�9[08]X�9[08]
    secondary DNS address 220.226.100.40
    pppd: `�9[08]X�9[08]

This is my wvdial.conf file;

[Dialer Defaults]
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Modem Type = Analog Modem
Baud = 9600
New PPPD = yes
Modem = /dev/ttyUSB0
ISDN = 0
Phone = #777
Password = 9382741646
Username = 9382741646

Is there any mistake in the config file ?

Should I do any thing after I run wvdial in terminal to get the internet to work ?

share|improve this question
    
Found the answer :-) –  John Nov 13 '13 at 3:28
    
so post it as a answer: May helpful for others. –  user224082 Nov 13 '13 at 3:39
    
@Dumindu ya i tried to post it. But i am not allowed to post it for 8 hours since my reputation is less than 10. Ill post it after 8 hours. –  John Nov 13 '13 at 3:41

1 Answer 1

Found the answer and thought to share it with you guys.

Install the these packages in the following order

  1. libwvstreams4.6-base_4.6.1-5_i386. get this - packages.ubuntu.com/lucid/libwvstreams4.6-base
  2. libwvstreams4.6-extras_4.6.1-5_i386. get this - packages.ubuntu.com/lucid/libwvstreams4.6-extras
  3. libuniconf4.6_4.6.1-5_i386. this one - packages.ubuntu.com/lucid/libuniconf4.6
  4. wvdial_1.61-4.1_i386. and finally this one - packages.ubuntu.com/lucid/wvdial

Download the amd64 for 64bit os and i386 for 32bit os systems.

Then go to /etc/wvdial.conf in sudo mode and edit it using vi with the following configurations.

[Dialer Defaults]
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Modem Type = USB Modem
CBaud = 460800
New PPPD = yes
Modem = /dev/ttyUSB0
ISDN = 0
Phone = #777
Stupid Mode = 1
Password = Your number
Username = Your number

the Modem = /dev/ttyUSB0 value may be /dev/ttyUSB2 based on which port your device is attached.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.