Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed Oracle Java 7 JRE under Ubuntu 12.04, and I am trying to get firefox (v. 22) to recognize it as a plugin. I've carefully followed these instructions:

http://sites.google.com/site/easylinuxtipsproject/java

All goes well; typing "java -version" at the command line turns up the correct (newly installed) JRE. In addition to the above instructions, I've also added sim links to the new libnpjp2.so in various places that firefox might be looking for plugins, beyond ~/.mozilla/plugins/.

However, firefox refuses to see it as a plugin. Typing "about:plugins" in the URL bar lists a bunch of plugins, but Oracle Java 7 JRE is not among them. When I look at my pluginreg.dat file, the full path to the new shared object, which is

/opt/java/32/jre1.7.0_45/lib/i386/libnpjp2.so

is shown at the bottom of the file, in the [INVALID] block.

I even tried running the elaborate script given here

http://www.duinsoft.nl/packages.php?t=en

as an alternative method to install Java 7 and get firefox to see it as a plugin, but I got the same result.

Interestingly, I have another Ubuntu box, that one running 10.04 with firefox v. 20 instead of v. 22, and the first method I mentioned goes without a hitch (with firefox seeing the plugin).

The Oracle Java install seems to be going fine. It's getting firefox v. 22 to recognize the plugin that is not working. Any suggestions or help would be warmly received.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Try the instructions/PPA described here: http://www.webupd8.org/2012/01/install-oracle-java-jdk-7-in-ubuntu-via.html

I installed Java 7 using that method, and the plugin has been picked up by Firefox (currently 25.0). I am currently on Ubuntu 13.04, but this has worked on 12.04 as well.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.