Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to compile bochs with this command:

./configure --with-x11 --with-wx --enable-ne2000 --enable-iodebug --enable-disasm --enable-debugger --enable-e1000 --enable-usb --enable-pci

it works, but then when I run make I got:

usr/bin/ld: gui/libgui.a(gtk_enh_dbg_osdep.o): undefined reference to symbol 'pthread_create@@GLIBC_2.2.5'
/lib/x86_64-linux-gnu/libpthread.so.0: error adding symbols: DSO missing from command line

Any Help ? :/

share|improve this question

2 Answers 2

You need to add -lpthread to the Makefile under LIBS

share|improve this answer

The problem occurs when configuring a Bochs build with --enable-debugger, and seems to be a bug in Bochs's automatic build configuration wherein it incorrectly omits -pthread from the linker flags on Linux platforms.

There is no need to edit the Makefile as suggested in the previous answer. Rather, the workaround is to specify LDFLAGS='-pthread' when configuring the build; for example:

./configure --enable-debugger LDFLAGS='-pthread'

I've filed bug report #1364 with the Bochs project. Please chime in over there to make sure the developers note and fix this bug.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.