Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am having problem with Ubuntu 13.10 brightness control. My brightness shortcut keys (Fn + F5/F6) worked in 12.10 and 13.04 but they have stopped working in 13.10.

I am using Sony Vaio SVE15113ENB with VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09). Any help is appreciated.

I have tried following options, but none of them has worked so far:

  1. Installing Additional Drivers from Software Centre
  2. Finding /etc/X11/Xorg.con file for editing but it does not exist for me.
  3. Visited Software & Updates > Additional Drivers tab, but it shows nothing saying 'No additional drivers available' and 'No proprietary drivers are in use'.

Thanks in advance for any help.

share|improve this question
add comment

1 Answer

Try this.

  • Execute $ sudo gedit /etc/default/grub

  • Modify the line GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" to:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"

  • Save the changes.

  • Execute $ sudo update-grub

  • Reboot.

Archlinux Wiki on brightness controls here.

share|improve this answer
    
Thanks @Pavel for your response. I tried this approach, with an additional reference to another similar question askubuntu.com/questions/366710/… –  Ninad Nov 13 '13 at 9:36
    
But it did not work. Is there anything I could check with driver installations? Or does Ubuntu installation come packaged with sufficient drivers to make all standard features of a laptop work out-of-box? –  Ninad Nov 13 '13 at 9:43
    
Your laptop may need some more tweaking as mentioned on this Arch wiki page in the ACPI section: wiki.archlinux.org/index.php/backlight. Try it. –  Pavel Nov 13 '13 at 14:35
    
I am able to set brightness from Terminal using commands echo 4000 | sudo tee /sys/class/backlight/intel_backlight/brightness and cat /sys/class/backlight/intel_backlight/brightness. Could you suggest a way to trigger them using Fn+F5 or Fn+F6? –  Ninad Nov 13 '13 at 19:38
    
Before we reach there: have you tried ALL grub file options from the Arch manual? And can you change brightness from System Settings > Brightness & Lock? –  Pavel Nov 13 '13 at 21:07
show 4 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.