Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I've installed Juju-GUI service I need to see it's public address. When I type:

juju status

System gives me the following output:

environment: local
machines:
  "0":
    agent-state: started
agent-version: 1.16.3.1
dns-name: 10.0.3.1
instance-id: localhost
series: precise
  "1":
agent-state: started
agent-version: 1.16.3.1
instance-id: server-local-machine-1
instance-state: missing
series: precise
services:
  juju-gui:
charm: cs:precise/juju-gui-79
exposed: true
units:
  juju-gui/0:
    agent-state: pending
    agent-version: 1.16.3.1
    machine: "1"
    public-address: 10.0.3.214

And I see that my Public address is 10.0.3.214, but my subnet is 10.0.1. and my local address is 10.0.1.49 I also noticed that after installing Juju, system added my strange network interface called:

lxcbr0

How can I change public address of service?

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

You are running locally using LXC and the IP address you see is the IP address of the Juju GUI inside the LXC. You cannot change it.

The lxcbr0 interface is created by LXC.

From your host machine you should be able to access the GUI by going to 10.0.3.214 in your browser.

share|improve this answer
    
Can I access it from other computers? –  Nikita Zernov Nov 12 '13 at 13:23
    
No, unless you enable IP forwarding and set up some kind of routing - it's a local network on the host machine. –  dimitern Nov 13 '13 at 10:49
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.