Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently installed Ubuntu 13.10 in a dual-boot with Windows 7, so I'm still quite new to using Linux. Most things were working fine, and I could log in normally (apart from the first login after install, which spent about 2 minutes on a black screen before going to the desktop). I installed the restricted Nvidia drivers with the command:

sudo apt-get install nvidia-current

Since then, after I enter my password and log in (the login screen itself works perfectly), I get a black screen with the cursor and nothing happens from that point onwards.

Basically, what I would like to know is how to get back to the normal Ubuntu desktop and (hopefully) still be able to use Nvidia drivers.

share|improve this question
add comment

4 Answers 4

up vote 2 down vote accepted

Like the first answer removing the xorg.conf file will reset your "driver-setup".

But I've had this problem or one very similar myself. The problem lay in Optimus, a nvidia technology that allows the user to switch back and forth between integrated and nvidia graphics in order to safe power.

Now I'm assuming now that you've got optimus, if not that you can ignore this solution. You can install a program called Bumblebee that installs and manages your graphical drivers including Optimus.

to install (make sure to purge your current-nvidia settings before!!):

 sudo apt-get install bumblebee bumblebee-nvidia

then reboot

sudo shutdown -r now

then after crossing your finger and a succesfull login. You can run programs using nvidia graphics using the optirun command:

optirun yourprogramnamehere

there you have it Optimus working and running.

share|improve this answer
1  
Won't this disable the hdmi or whatever external screen is directly attached to the Nvidia directly? –  NoBugs Jan 11 at 22:10
    
Indeed, when I installed bumlebee my external hdmi displays didnt work anymore. However, they didn't work well with default drivers either.. –  Christophe De Troyer Feb 24 at 8:43
add comment

I had the exact same problem and after searching for hours i got the solutions. Problem was, that due to installation of some software's like opencv it automatically installed nvidia drivers/graphics on NON-NVIDIA machine and due to this screen goes blank. So Just follow these simple steps to get your desktop screen back:

  1. Press Ctrl+Alt+F1
  2. Provide Login details.
  3. Type in terminal:

sudo apt-get remove --purge nvidia-*
sudo reboot

Done!

share|improve this answer
add comment

I am running dual 660Ti cards, with sli,and dual monitors. I had a similar problem. The main screen would boot properly, but my second screen was black. I could see in the display settings that the screen was detected, and should have been functioning. I don't know the root cause yet, as I am new to ubuntu, but I simply pressed the analog/digital select capacitive button on the front of the monitor. Now the monitor works properly. I know this is not a permanent solution, but I have seen similar results, from other users, with the brightness buttons. This may help you, until you can resolve the root cause issue.

share|improve this answer
add comment

I am new to Linux and have no idea about it.. I searched it and I had same problem just tried

CTRL+ALT+T then sudo apt-get remove fglrx

and done...

as i was not able to use CTRL+ALT+T in my login id..so i used it from guest id .. and then re logged in without turning pc off.. and it worked

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.