Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I try to boot I get this message:

error: unknown filesystem. grub rescue> _

results of:

grub rescue> ls

are as follows:

(hd0) (hd0,msdos5) (hd0,msdos1) (hd1) (fd0)

share|improve this question
Hey I am having the same problem as you had of grub rescue how did you fixed it? can you explain me. – user2014111 May 22 '14 at 7:33
Honestly, user2014111, I actually had to copy the files off of the HDD, and then I re-installed the whole OS. Sorry I couldn't be of more help... -Chandler – Chandler R. May 22 '14 at 14:43

If you don't know your Ubuntu boot partition, check them one by one:

ls (hd0,msdos5)/
ls (hd0,msdos1)/

When you hit the right one, you'll get a line mentioning "lost+found" and so on.

Assuming (hd0,msdos5) is the right partition:

set root=(hd0,msdos5)
set prefix=(hd0,msdos5)/boot/grub
insmod normal

Now you'll be able to boot into Ubuntu. Once you do, reinstall GRUB:

sudo update-grub
sudo grub-install /dev/sda
share|improve this answer
I ran the first two commands with (hd0,1) in place of (hd0,5) as (hd0,msdos1) was the correct partition... they produced no message so I assumed they worked, but when I ran insmod normal... it gave me this message: error: file not found. Then I ran the normal command and it rebooted to the same problem (unknown filesystem) I am running 12.04 LTS Server Version if that changes anything. Thanks again! – Chandler R. Nov 12 '13 at 16:18
Nevermind that. I got it fixed! Thank you so much! – Chandler R. Nov 12 '13 at 16:45
Ur wlcm. Plz mark as answered. – Pavel Nov 12 '13 at 18:07
thank you very much.. life saver! – Sumoanand Jan 27 '14 at 8:31
Hi Chadler..i am getting file not found error when i type insmod normal. please help me – Ekaveera Apr 4 '14 at 6:22

If you have a UEFI bios make sure you boot through uefi boot and not legacy. Grub is actually there but the bios doesn't allow it to start

share|improve this answer

The easiest way i found to fix this error was to put in an old windows 98 disk and in dos you can delete and create partitions and then format

share|improve this answer

protected by Community Oct 25 '14 at 10:37

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.