Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am experiencing file sync failure in Ubuntu One at 12.04 for about one month It happened without any notice and still continues.

<> When I launch Ubuntu One, File Sync does not start. When I click "Sync File" button in top right, it says "auth failed (AUTH_FAILED)" and gives dialog "I am sorry but we need to close Ubuntu One due to erros" (message in Japanese, so this is my translation), with the following output:

UnauthorizedError
u'\u30db\u30b9\u30c8\u306e\u8a8d\u8a3c\u304c\u5fc5\u8981\u3067\u3059'
u'OAuth required (mandatory).'

(It seems that these strings are Unicode character, possibly UTF-8 string. It that Japanese file name?)

No account information and Current Service displayed. By clicking "Edit Service Online" button, web page shows only "OAuth required (mandatory).", possibly authentication error.

<> I re-installed all related packages to Ubuntu One (tried to remove settings), and produced no improvement. I also removed all files possibly related to Ubuntu One manually by:

sudo rm -rf ~/.local/share/ubuntuone
rm -rf ~/.cache/ubuntuone
rm -rf ~/.config/ubuntuone
mv ~/Ubuntu\ One/ ~/Ubuntu\ One.orig/

and restarted computer. These procedures brought no betterment for this inconvenience.

Moreover, my another Ubuntu instance (also 12.04) met the same Ubuntu One error today and it still continues.

Does anyone suggest solution or at least the reason? Thanks,

share|improve this question
    
Have you tried deleting the Ubuntu One token entry in your keyring, and then restarting the Ubuntu One sync service (or logging out and back in on your computer)? –  dobey Nov 13 '13 at 1:27
add comment

1 Answer 1

I tried to delete the ubuntu one token from the gnome keyring by using seahorse. There was a token called 'UbuntuOne token for https://ubuntuone.com' and I tested the keyring like mentioned here: https://one.ubuntu.com/help/faq/how-do-i-check-my-oauth-tokens/

python ./ubuntuone-oauth-token-validator.py

But it failed with error 401

After deletion of that corrupt token, and reloading u1, u1 asked me again for my credentials. I put in my u1 username and password, and u1 started to sync again. Thanks to dobey.

share|improve this answer
    
Thanks, GerhardG, and sorry for late reply. As Ubuntu One no longer provides its service, I cannot validate whether the answer is right. However, according to Ubuntu One person (I asked him/her via question form), the method is really similar. They suggested that deleting keys relating to Ubuntu One from Gnome Keyring, and it seems worked. –  terakinizers May 7 at 4:54
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.