Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to install the Catalyst driver. The best I can get is a strange resolution problem and firefox acts all wonkt. The worst I have gotten is low graphics mode in which I just reinstall Ubuntu.

I have a HP Pavilion Dv7 laptop. With Radeon 3200 HD. I plan to try again with a fresh install of Ubuntu 12.4.3 as I have heard its the most compatible.

This is what I have done:

  1. I have tried just the easy way of going to synaptic and installing the drivers that way. the fglrx package (not the fglrx update). And if memory serves I think that boots me into low graphics mode. So, fresh install of Ubuntu and tried again.
  2. I have done everything a couple times from this site (http://wiki.cchtml.com/index.php/Ubuntu_Precise_Installation_Guide) following every instruction to a T. That gets me something, such as a lowered fan speed and a much cooler computer, but I also lose most of my resolution. And displays says its the best resolution I can get. I also have a very screwy firefox. Using this method I can see AMD Catalyst Control Center in my dash (two of them really one administrator and one not) but when I try to open it it says no amd driver detected. So again, ubuntu reinstall.
  3. I have tried the GUI method from the Legacy driver I got from AMD's site. It runs through smoothly and at the very end after I exit the installer it gives me an error.
  4. I have also tried various other methods using terminal, as well as various different drivers (the one from the amd's site and the one suggested in the above link for my graphics card) both to no avail.

When I try the method in the link on number 2, and I get the super low res and screwy fire fox. I type in, fglrxinfo ,and get a badrequest error. I have yet to type in fglrxinfo and get anything like what I am supposed to.

UPDATE: I am now currently reinstalling Ubuntu 12.4. I tried the above mentioned link - thank you very much!- just to see on the previously failed driver attempt by following the purge commands. And to no avail when typing fglrxinfo I still get the badrequest thing. I will update again after a try with a true fresh install. Thanks again!!

UPDATE: Alright everyone. Still no go. I have done everything word per word in the provided tutorial. I have rebooted my computer again to a messed up resolution and this is what I get when typing fglrxinfo:

$ fglrxinfo
X Error of failed request:  BadRequest (invalid request code or no such operation)
  Major opcode of failed request:  153 (GLX)
  Minor opcode of failed request:  19 (X_GLXQueryServerString)
  Serial number of failed request:  12
  Current serial number in output stream:  12

I would like to add that when installing this file: fglrx_8.970-0ubuntu1_amd64.deb

I got this:

Building initial module for 3.8.0-29-generic
Error! Bad return status for module build on kernel: 3.8.0-29-generic (x86_64)
Consult /var/lib/dkms/fglrx/8.970/build/make.log for more information.
update-initramfs: deferring update (trigger activated)
Processing triggers for ureadahead ...
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Processing triggers for initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-3.8.0-29-generic
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place

Any ideas? Anyone? I cant for the life of me figure out what I am doing wrong.

UPDATE: SUCCESS!! I downloaded and installed Ubuntu 12.4.1 and it installed the drivers automatically. Score one for team Ubuntu. This is the link for 12.4.1 http://old-releases.ubuntu.com/releases/12.04.1/ubuntu-12.04.1-desktop-amd64.iso

share|improve this question
1  
I tried that. See Update. –  bittoast67 Nov 12 '13 at 5:36
    
@Braiam Just wanted to say again. Tried everything this tutorial said and to no avail. Again see update. –  bittoast67 Nov 12 '13 at 9:00
    
Can you add the output of sudo lspci -nnk | grep -A5 VGA? –  Braiam Nov 12 '13 at 12:20
add comment

1 Answer

The problem is that the legacy driver is not compatible with the kernel you are trying to use. The default kernel in Ubuntu 12.04.3 is 3.8. The legacy driver only supports up to kernel version 3.4. The only version that will work for you is the original 12.04.1 release with kernel 3.2

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.