Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I have some node executables installed on an Ubuntu server but whenever I try to execute them nothing happens. I don't even get an error message. I know they're in my path because which executable_name works. When I do which -a node I get two outputs:


I feel like this has something to do with the problem but I have no idea what to do. Help.

share|improve this question
more information here :… –  ctesniere Sep 23 at 17:08

2 Answers 2

up vote 8 down vote accepted

According to this answer:

sudo apt-get --purge remove node
sudo apt-get --purge remove nodejs
sudo apt-get install nodejs

# Confirm it worked
node --version       # v0.10.13
ls -la `which node`  # ... /usr/bin/node -> /etc/alternatives/node

Solved my problem.

share|improve this answer

Probably sudo apt-get install nodejs-legacy would also do what you want. See

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.