Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have mid-2010 MBP, left of 1 it has §± key, apparently in some older models that are the only ones mentioned in Ubuntu docs, there used to have `~ key there. In Ubuntu 11.04 with US-Mac keyboard layout I have them swapped. The issue occurs only with built-in keyboard, with external one it works fine. Is there an easy way to fix that?

The layout I have is same as this:

share|improve this question
add comment

3 Answers 3

Thats a British keyboard with the £ above the 3, but annoyingly, unlike a British PC keyboard, Apple put the @ above the 2 where the " should be!

share|improve this answer
add comment

Try going to System > Preferences > Keyboards and check what layout is being used with the external keyboard. If it differs from the integrated keyboard that is giving you trouble, then just change the layout to the non-swapped one.

share|improve this answer
    
In 11.04 with Unity it's more like "System Settings > Hardware > Keyboard". I don't see any option to have different settings for second keyboard. –  vartec May 2 '11 at 9:19
1  
Woops sorry, I haven't touched Unity yet. And I might be wrong in this but I would just check the Layouts tab in Keyboards and verify which layout is active when you have the keyboard currently plugged in. If there's a difference between the two, the name of the layout that is enabled should change. –  zookalicious May 2 '11 at 18:09
add comment

You are mistaken about the type of keyboard layout you have. What you are describing/showing is NOT the usual US Macbook Pro layout, which has had `~ left of 1! for years (even before unibody). So you obviously have a non-American Macbook Pro or modified somehow and thus need to pick a different keyboard layout in the options.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.