Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Does anyone know how to adjust the default width for shell window in Ubuntu, so that I don't have to re-size it every time I open it up?

share|improve this question
    
What do you mean by "Shell Window"? –  Marco Ceppi Apr 28 '11 at 15:04
    
@Marco I think what they mean by "shell window" is the window for the terminal. –  Christopher Kyle Horton Sep 6 '11 at 17:33

4 Answers 4

If you are referring to gnome-terminal, you can go to the menu item Edit->Profile Preferences, check "Use custom default terminal size" and put in the character dimensions you prefer.

share|improve this answer
    
BTW, that setting is stored in ~/.gconf/apps/gnome-terminal/profiles/Default/%gconf.xml by default –  l0b0 Apr 28 '11 at 14:44
1  
@l0b0: I would say that it can also be modified through gconf-editor, following the path /apps/gnome-terminal/profiles/Default, in the values of use_custom_default_size, default_size_columns and default_size_rows. I would never suggest to edit the file directly. –  enzotib Apr 28 '11 at 14:51
1  
there are 6 tabs available in my "Profile Preference" window, General, Title and Command, Colors, Background, Scrolling, Compatibility, and I can't find "Use custom default terminal size" –  user15218 Apr 28 '11 at 15:09
1  
@user15218: in the General tab, at the bottom of it. –  enzotib Apr 28 '11 at 15:13
    
@user15218: The setting is not available in 10.04 alternative install, nor is there use_custom_default_size setting in gconf-editor. –  Coder Jan 17 '12 at 17:43

Add this to ~/.Xresources (of course with whatever dimensions you want):

XTerm*VT100.geometry: 96x68

Then add this to ~/.xinitrc:

xrdb -merge $HOME/.Xresources

That should be sufficient. Unfortunately it looks like it's necessary to log out and in again to see the changes.

share|improve this answer
    
why don't I have ~/.Xresources, it says No such file or directory –  user15218 Apr 28 '11 at 14:32
1  
@user15218 It's not there by default. –  l0b0 Apr 28 '11 at 14:33

With gnome-terminal use Edit->Profile..., select the default profile, then edit. In the next window in the general tab there is the option to select the window size. You have to open a new terminal window to see it work.

share|improve this answer

You can automate this with a script:

gconftool -s /apps/gnome-terminal/profiles/Default/use_custom_default_size -t bool true
gconftool -s /apps/gnome-terminal/profiles/Default/default_size_rows       -t int  60
gconftool -s /apps/gnome-terminal/profiles/Default/default_size_columns    -t int  220
gconftool -s /apps/gnome-terminal/profiles/Default/scrollback_lines        -t int  5000
gconftool -s /apps/gnome-terminal/profiles/Default/background_type         -t string transparent
...
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.