Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have searched this forum and the Internet for hours looking for a way to get to the gnome-control-center sound -> output volume by command line so that I can put it into a script to set it on boot up as it keeps going to NULL no sound -- turned down all the way

all I have found is how to get to the GUI which is a bother to have to start up every time I boot up as well as I am setting up a conky xmms2 window which works but my volume is always turned completely down by UBUNTU gnome-control-center sound settings every time I boot up -- I seen that it seems to be a bug and has been put on 'low' concern to fit it.

I have found how to set(ALSA) amixer setting that works but it does not tie into the gnome volume settings all I can find IN HERE is how to start up the GUI by typing 'gnome-control-center sound' to set it not by or like ( amixer -c 0 set Master playback 100% unmuteu ) which works for my mixer setting still the gnome volume is set completely to 0 (zero) at the same time. pulseaudio works to but in the same manner it seems that the gnome is the master of all the sound controls and it is being a little S*$%! in not cooperating

I've tried gnome-control-center sound -c 0 set Output volume 100% unmuteu and various other ways to try and get it to work

I've looked for the properties after the ?Class 'sound' I have not found any documentation to tell me what or how to get past the sound call to get to the volume setting itself in order to set it to what ever level I want in a shell script

if anyone else knows please share as I cannot find any documentation on it myself

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.