Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

since I use Ubuntu 13.10, I'm experiencing a bug:

  1. I activate standby
  2. I press any key to continue working on my laptop
  3. The computer is on again, but the wlan doesn't work.

After Standby… Hitting "Enable network"

→ The wlan network then is disabled by default, but I can't enable it, it doesn't shows any network available.

share|improve this question
up vote 2 down vote accepted

It could be a problem of the driver or of network manager. In the latter case, try to see if

% sudo restart network-manager 

works. If it works, you can add the network-manager restart at resume: there are a lot of hints and suggestions here: how to execute a command after resume from suspend?

Otherwise, you should try to load/unload the wireless driver --- you can find it with

% nm-tool | grep Driver
Driver: atl1c
Driver: ath9k 

(you will have the list of drivers, one of them is you wireless one), and try to unload and reload it:

sudo rmmod ath9k
sudo modprobe ath9k

If this second option does work, you can add the modules to the list of modules to be loaded/unloaded at suspend/resume,

% sudo sudo gedit /etc/pm/config.d/config

And adding


there. (Disclaimer: it worked for me in 12.04. Never tried with newer Ubuntu).

share|improve this answer
thanks a lot! the third one worked for me. – IndexOutOfBoundsException Nov 12 '13 at 20:34

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.