Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Love juju and this ceph charms is great. Can you help with this issue ...

I have deployed the ceph charm to a MAAS cluster of 3 nodes (machine: 0, 1, & 2)

I used this command to deploy:

juju deploy --config ./ceph.yaml -n 3 ceph

Now when I check the juju status I see that ceph has gone to machine: 1, 2, & 3. Since I don't have a machine 3 it is pending.

How can I get it to deploy to the 3 node I already have ?

Here is my juju status...

juju status
2013-11-11 20:46:51,893 INFO Connecting to environment...
2013-11-11 20:46:52,563 INFO Connected to environment.
machines:
  0:
    agent-state: running
    dns-name: 8ypjm.ceph
    instance-id: /MAAS/api/1.0/nodes/node-d8686094-48c9-11e3-b313-deadbeeefb1a/
    instance-state: unknown
  1:
    agent-state: running
    dns-name: a8nke.ceph
    instance-id: /MAAS/api/1.0/nodes/node-88a58b34-48cb-11e3-9d7d-deadbeeefb1a/
    instance-state: unknown
  2:
    agent-state: running
    dns-name: f7fby.ceph
    instance-id: /MAAS/api/1.0/nodes/node-c7d89b0c-48cb-11e3-b313-deadbeeefb1a/
    instance-state: unknown
  3:
    instance-id: pending
services:
  ceph:
    charm: cs:precise/ceph-16
    relations:
      mon:
      - ceph
    units:
      ceph/0:
        agent-state: start-error
        machine: 1
        public-address: a8nke.ceph
      ceph/1:
        agent-state: start-error
        machine: 2
        public-address: f7fby.ceph
      ceph/2:
        agent-state: pending
        machine: 3
        public-address: null
2013-11-11 20:46:52,999 INFO 'status' command finished successfully
share|improve this question

1 Answer 1

In order to place units on machines, you need to use the placement directive --to.

You can't use this when specifying number of units however.

So you'd have to go:

juju deploy --config ./ceph.yaml ceph --to 0
juju add-unit ceph --to 1
juju add-unit ceph --to 2

This is assuming that you already having machines 0, 1 and 2 in existence.

share|improve this answer
    
agent-state: start-error is also bad - this would indicate misconfiguration of the deployed charm against the server - please check the fs-uuid and mon-secret's have been supplied and that the block devices you are trying to use on the server exist. –  jamespage Nov 11 '13 at 14:30
    
That is great.Thanks for the pointers on deployment. I have deployed a 4th node (machine 3) and now have 3 agents in start-error. I think this is a separate topic so I'll close this one, do some testing and research and open another if required. –  davegempton Nov 12 '13 at 1:49
    
Looks like my issue was DNS related. The celerybeat job that sync dhcpd.leases into the zone file does not seem to be working on my system. I manually added the address lines into the zone file /etc/bind/maas/zone.ceph then restarted named. Used juju to destroy-service ceph then deployed it again and this time it all worked. –  davegempton Nov 12 '13 at 2:35
    
I have tested this answer and it didn't work for me: $ juju deploy --config ./ceph.yaml ceph --to 0 gave me an error "juju: error: unrecognized arguments: --to 0" –  davegempton Nov 21 '13 at 4:13
    
machine 0 is the zookeeper. As of Nov 2013 juju 0.5+bzr531-0ubuntu1.3 is the current juju package in the Ubuntu archive. This version does not support the option --to. It won't let you deploy any charms to the zookeeper. –  davegempton Nov 26 '13 at 21:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.