Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This problem is really weird. If I log into Google chrome, I can not use Google to search. And I cant log in to sites like this one and Stack Overflow with my Google account. The pages time out with "no response from server" type errors.

If I use a Windows PC on the same network it is fine, but in Ubuntu or Mint it fails. The problem started a month ago so I switched from Mint to Ubuntu with no improvement.

When I search Google (not logged into Chrome) the results pages are usable. But if I log into Chrome, I get a page of results that I can't click on unless I manually change the link. For example this link:

https://www.google.co.nz/url?sa=t&rct=j&q=&esrc=s&source=web&cd=2&cad=rja&ved=0CDgQjBAwAQ&url=http%3A%2F%2Fwww.nzherald.co.nz%2Fnews&ei=q2GAUpPmJMSNkwWU8YG4Bw&usg=AFQjCNERHzAW7KHDOJWr2jgIYL8ag5QciA&sig2=C5IAdaYSIk8U0a1LJwq-Yg&bvm=bv.56146854,d.dGI

Fails to redirect, but if I open in a new tab and change the google.co.nz/ to google.com/ it will load.

DNS lookups are working fine using dig or nslookup to confirm.

Does any one have a clue as to what to try next? This a now a fresh install of Ubuntu 13.10, but had the exact same problem on Mint and a Windows PC works fine (how I am logged in now).

share|improve this question
    
Have you cleared your cache and/or used firefox/chrome? If I have to guess your google account is gliched, maybe you need to logout all sessions. –  Braiam Nov 11 '13 at 5:10
    
Yes, when chrome has problems searching firefox search results are usable, but I still can not log into sites using firefox and my google id on linux. Deleting the user account in chrome returns it top a form of usability until once again I try to use the google id. –  Rob Nov 11 '13 at 5:12
    
Try checking the Omnibox settings. Right click on it and then click on "Edit Search Engines." Maybe your defaults got messed up. –  kelvinilla Nov 11 '13 at 5:36
    
Maybe google.co.nz/ is the one causing the problem. Try going to the international site and then set the search box as your default search. –  kelvinilla Nov 11 '13 at 5:46
    
I just tried, but no joy, It works until I log into chrome. Then the search fails again. I could understand if a corrupt gogole account brke chrome, but it also partially breaks firefox, and it's working fine on windows, –  Rob Nov 11 '13 at 5:48

1 Answer 1

Ok, I finally solved the problem using plain old dumb luck and persistence.

I have lost the link, but via many searches I came on a path to a Russian web site (translated to English by Google) where people had similar problems with a range of TP-Link routers, the same brand as my ISP provided to me.

The solution was to lower the MTU from it's default 1500 to 1400. Maybe higher will work, but for today I am a believer in "Don't fix what isn't broken"

I hope this helps some one else :-)

share|improve this answer
    
what is the difference between this and your other answer 408 error in browser using Google or openid on some networks in Ubuntu? –  Braiam Nov 23 '13 at 13:47
    
Nothing, it's copy and paste, same solution, and I guess the same problem with different symptoms. –  Rob Nov 24 '13 at 17:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.