Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Ubuntu won't detect my external monitor. I'm running Ubuntu on a Lenovo ThinkPad W530 with NVIDIA Corporation GK107GLM [Quadro K1000M]. I've been told to run nvidia-settings, but When I try running it, I get the following:

You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run nvidia-xconfig as root), and restart the X server.

When I do so, I get a 640x480 resolution. Additionally, when I run nvidia-settings again, I get the same error message.

What can I do to fix this?

UPDATE: I upgraded to Ubuntu 14.04 and it works now.

share|improve this question

1 Answer 1

Thinkpad models with optimus have some of their external displays connected directly to the nvidia card, and the thinkpad display is connected to the integrated intel card. (See this blog post).

Easiest workaround (at least on the W520) is to go into the bios and change the display mode from "nvidia optimus" to "discrete". This will cause the laptop to ONLY use the nvidia card on all displays, which makes it possible to use multiple displays, but significantly decreases battery life. There are also more complicated workarounds that can allow for better battery life.

share|improve this answer
    
I've changed the display mode to discrete, but the problems persists. My external monitor is still not being detected and nvidia-settings still won't work either. Any other suggesstions? –  Daniel Que Nov 11 '13 at 1:28
    
Delete your xorg.conf (you can make a backup if you want). Use $ locate xorg.conf to find it. It's probably in /etc/X11. This file was created when you ran nvidia-xconfig, and may be causing the X server to start with the wrong settings. Also, you have nvidia-current installed, right? –  Zach Nov 12 '13 at 7:35
    
Or, try installing clean ubuntu on another test partition, install nvidia-current and nvidia-settings, and then put it in discrete bios mode and see if it works (you might have changed something else along the way that messed it up - optimus is finicky) –  Zach Nov 12 '13 at 7:39
    
I've just installed Ubuntu 14.04 and it works now. I'm not sure what the problem was though. Thanks for your help! –  Daniel Que May 3 at 19:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.