Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've started using Conky with 11.04 and want to remove it's drop shadow. I've tried setting any & !(class=Conky) in the Shadow Windows text box of the Window Decoration section. This works. However, every time I try and use either the global menu or an app indicator menu, compiz crashes. Not all the time, it seems quite random on which menu it chooses to crash on, but it happens enough to not use this method.

So I was just wondering if there was any other way of removing the shadow from the Conky window.

Thanks,

share|improve this question

4 Answers 4

up vote 5 down vote accepted

To solve these problems, don't paste the settings for opening in a new window, just delete the code.


What to delete (usually if you copied the code, it has this):

#Create own window instead of using desktop (required in nautilus)
own_window yes
own_window_hints undecorated,below,skip_taskbar
background no
share|improve this answer

I'm not sure how you're editing settings (the Window Decoration section of what?) but I have draw_shades no in my .conkyrc and no drop shadows. Lifehacker has a whole thread of Conky configs, too. Might be worth digging around there if you're trying to fine tune things.

share|improve this answer
    
Thanks for the response. I was using the Compiz Config Settings Manager. I already have draw_shades no in my .conkyrc file, but it doesn't do anything. Can't see anything straight away in the lifehacker page, but I'll continue searching. –  Josh Apr 28 '11 at 13:05
    
@Josh, I'm still on 10.04, but my settings for Window Decoration > Shadow Windows and Window Decoration > Decoration Windows are both "any." –  Amanda Apr 28 '11 at 18:54

I think what you need is to replace own_window_type normal with own_window_type override .

share|improve this answer
    
This one is useful for me, thanks! –  Reorx Nov 26 '13 at 8:11

this worked better for me:

...
own_window          yes
own_window_type     desktop
own_window_hints    undecorated,below,sticky,skip_taskbar,skip_pager
double_buffer       yes
no_buffers          yes
...

The accepted answer caused Tint2 to flicker/occasionally restart

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.