Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Noob here. I just installed 13.10 yesterday And it booted up for me several times and all was well. Then this morning when I went to boot I received a "No such device" error and a "grub rescue" command line prompt. I tried running the live disc and re-installing Ubuntu 13.10 However that was a fail. The same messages kept occurring. Then I tried to boot up in Windows 7. Also a fail. I then attempted to run a Windows 7 restore disc. You guessed it - Fail. This sucks. What do I do?

share|improve this question
check your boot order in bios. – Avinash Raj Nov 11 '13 at 0:39

I can't comment, but did you end up upgrading grub at some point? This causes many people errors... And be more descriptive what grub rescue line comes up

share|improve this answer

You can fix GRUB via the Ubuntu install disk. You do not need to re-install Ubuntu. When initially opening the Install disk there is an option to Repair Ubuntu. Click through the various screens until you get to a menu that mentions repair (or re-instal grub). Choose that menu option and the system will rebuild grub for you (including recognising Windows partition and adding a grub menu option for that).

Hope this helps

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.