Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When Ubuntu starts up, Unity fails to load (I can only see my desktop with no unity sidebar and no system bar in the top right).

I tried the advice of Unity does not start in Ubuntu 13.04

which recommended the following commands:

dconf reset -f /org/compiz/ 
unity --reset-icons &disown

I ran the commands without errors an restarted the computer, but the problem persists. I am currently running Gnome.

I have looked at other pages from the Google search "ubuntu unity failed to load 13.04", but the advice was similar to above and seems to be concerned with a system upgrade in April 18, 2013. I suspect my issue is something far more recent.

Please give me advice on how to restore Unity on my account or at least figure out what the problem is. Thank you.

Some information that might be relevant:

  • Unity has worked fine on 13.04 for the 6 months that I've had it until today. (November 10, 2013)
  • I have set up the update tool to automatically update when available. It is very possible that the system applied some updates without my knowledge.
  • Interestingly, Unity works fine on the Guest account.
  • I have made it so the system automatically logs me in at start-up.
  • This is a personal laptop. No one else has access to it.
  • I was not doing anything with the system settings or the terminal and have not installed any new software for the past 3 days.
  • I am running the System76 native Linux laptop Ultra Lemur. I did not contact their support yet because it seemed unlikely that this is a System76-specific error.
share|improve this question
1  
I have discovered the answer myself. The forum will not let new users answer their own question for 8 hours, so I have answered it here. I have left this question for posterity. It turns out you need to run the below commands while running Gnome (I was previously trying to do this while on the broken Unity) dconf reset -f /org/compiz/<br> unity --reset-icons &disown The Unity launcher appeared above the Gnome menubar. I logged out and logged in to Unity and everything works fine now. –  user152973 Nov 10 '13 at 16:10
    
That worked for me. In fact, running just the unity command (dconf errored on my machine). made it work. I used the ctrl+alt+F2 terminal to run the commands (not Gnome). –  Utkarsh Sinha Nov 12 '13 at 17:24

1 Answer 1

It turns out you need to run the below commands while running Gnome (I was previously trying to do this while on the broken Unity) dconf reset -f /org/compiz/ && unity --reset-icons &disown.

The Unity launcher appeared above the Gnome menubar. I logged out and logged in to Unity and everything works fine now.

(answer provided by OP in comments.)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.