Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Whenever I wake my laptop from sleep mode the SSD card is locked to the launcher. It is not though after booting.

How can I avoid this behaviour?

To avoid misunderstandings: I do want the SSD card to be mounted, I just don't want it to be automatically locked to the launcher.

Version: Ubuntu 13.10

share|improve this question
    
What is the location of your SSD? Is it in /media/[user] or have you designated a mount location? –  kelvinilla Nov 10 '13 at 19:03
    
Yes, it is in /media/[user] ... –  lpdbw Nov 11 '13 at 7:22

1 Answer 1

up vote 2 down vote accepted

The two conventional storage locations are /media and /mnt. The difference between the two are that /media is used for removable and /mnt is used for more permanent storage. Removable storage is always automatically mounted in /media and is shown on the launcher when mounted. On the other hand, storage mounted on /mnt (or anywhere else)* aren't shown on the launcher, which seems to be the one you want.

For this, you'll have to modify your fstab:

  1. Look up the device address of your SSD for reference later. An easy way is to go to the Disks app and find your SSD. The address should look like this: /dev/sda1. Also find out its file system type. For example, it could be ext4, FAT or NTFS.

  2. Open a Terminal and type in sudo gedit /etc/fstab.

  3. Type in the device address, mount point, file system type, options, dump and pass number, all separated by spaces. It should look like this:

    /dev/sda1 /mnt/[name] ext4 defaults 0 2

    Just fix the spaces to match the previous entries just for organization.

    *My preferred mount point is /mnt/archive. It can actually be anything that isn't already used by the system (e.g. /data, /storage). If you mount it in /media, like /media/storage, it will show up on the launcher.

    The full manual can be found here.

  4. Save the file.

  5. Restart the computer to take effect.

Cheers.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.