Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed Lubuntu 13.04 on a Dell Inspiron 1501 laptop, rebooted the machine and encountered this problem. I edited the GRUB configuration to remove "quite splash" and enter "nomodeset", updated grub, and everything was fine. I could reboot the machine without any trouble.

However, if I unplug the machine, wait a few seconds, and plug it back in, the problem with the colored lines comes back and nomodeset no longer helps to solve the problem. I tried using radeon.modeset=0 instead of nomodeset and that also works on multiple reboots until I unplug the machine and plug it back in. I was finally able to get around the problem by entering "radeon.exapixmaps=0" instead of radeon.modeset=0. I suppose I kind of made up that boot option using some information from an Arch Wiki page. This would work throughout reboots and even if I unplugged the laptop. It was working fine for quite a while.

A few weeks later, I had some unrelated issues with the Java iced-tea plugin, and since 13.10 had just come out, I thought I would try upgrading. So upgrading didn't fix the problem with Java, and after unplugging the machine and trying to use it later, I was back to this problem with the black screen and colored vertical lines.

I am completely out of ideas on what to try. It took me a week to figure out how to get it working the first time, but the solution I had isn't working anymore.

share|improve this question

1 Answer 1

up vote 0 down vote accepted

Well, I figured it out. The fact that unplugging the machine and plugging it back in led me to try out some of the other standard boot options. So using acpi=off in addition to nomodeset fixed the problem with the colored lines. However, it created the new problem of not completely turning off the computer when running shutdown.

This all turned out to be an issue with the BIOS. I painstakingly worked out how to update it and it looks like I don't need to have acpi=off anymore.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.