Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

this is my first post here.

My Dell Studio 1457's a great laptop and has been with me through thick and thin, but it has always had problems with the open source radeon driver. As fglrx is being left behind (amd not helping by no longer updating the proprietary driver) with the move into 13.10, I'm finding myself with a laptop that will still not resume from suspend with the radeon driver. The computer suspends successfully, but every time I resume the computer turns on, but I get a black screen with no LED backlight.

Again, this has always been a problem for me, since the 11.10 days. My graphics card is an HD mobility radeon 4530. I'm running Ubuntu Gnome 13.10.

Adding nomodeset as a kernel argument in /etc/default/grub does permit resume from suspend, but by doing that I miss out on excellent features of the new radeon driver in combination with the 3.11 kernel (radeon.dpm--which is WONDERFUL power management finally) and HDMI video out to external monitor (nomodeset leads to neither hdmi out nor VGA out being recognized in displays.)

I really don't want to give up on these features as I use an external monitor extensively, and it's so exciting seeing the open source driver working so flawlessly in these two areas.

I've tried pm-suspend quirks listed on the ubuntu manpage:

--quirk-radeon-off, --quirk-vbe-post, --quirk-vbemode-restore, --quirk-vbestate-restore, and --quirk-vga-mode3, to no avail. It always successfully suspends but resumes to black screen.

I've also tried the tuxonice kernel, first installing it, then setting pm-suspend to use tuxonice backend with

cat "SLEEP_MODULE=tuxonice" > /etc/pm/config.d/SLEEP_MODULE

Following that with a kernel arg addition in GRUB_CMDLINE_LINUX_DEFAULT of "resume=swap:/dev/sda2" (and I do have that swap partition.) Tuxonice, in a nutshell, didn't work either.

So as this laptop's both getting old (2009) and relatively far from the mainstream, I'm wondering if there's any way I've yet to try that I might get resume working properly under the radeon driver without nomodesetting it.

I fear it may be this laptop's crap BIOS, but I am open to suggestions.

share|improve this question
add comment

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.