Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just updated from Ubuntu 10.10 to 11.04 and have an issue regarding the screen resolution. I have Intel integrated gfx chip and my monitor supports resolutions larger than 1024x768. (in 10.10 I've been using 1280x1024) But as soon as I upgraded, I'm stuck with 1024x768 resolution and seems I can't change it. running

xrandr
In terminal yields the following results,

Screen 0: minimum 320 x 200, current 1024 x 768, maximum 4096 x 4096
LVDS1 connected 1024x768+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1280x800       58.1 +
   1024x768       60.0* 
   800x600        60.3     56.2  
   640x480        59.9  
VGA1 connected 1024x768+0+0 (normal left inverted right x axis y axis) 344mm x 194mm
   1366x768       59.9 +
   1360x768       60.0  
   1024x768       75.1     72.0     70.1     60.0* 
   832x624        74.6  
   800x600        72.2     75.0     60.3     56.2  
   640x480        72.8     75.0     66.7     60.0  
   720x400        70.1  
  1280x1024_60.00 (0xce)  109.0MHz
        h: width  1280 start 1368 end 1496 total 1712 skew    0 clock   63.7KHz
        v: height 1024 start 1027 end 1034 total 1063           clock   59.9Hz

What maybe the problem? Is it a bug? What kind of steps I should take in order to get a higher resolution? (changing xorg.conf maybe?) Any insight is highly appreciated. Thanks in advance.

UPDATE

enter image description here

Screenshot after running

xrandr --addmode VGA1 1360x768

As you can see, side bar is not completely visible and Ubuntu logo at the task bar is missing. Also when you open an application, the Task bar of the application (where it should go to the top panel) is missing as well..

share|improve this question
1  
I keep coming back to this question over and over, sigh... –  AlexanderN Mar 19 '13 at 14:07
add comment

closed as off-topic by searchfgold6789, Olli, Eric Carvalho, BuZZ-dEE, user68186 Feb 26 at 18:39

This question appears to be off-topic. The users who voted to close gave this specific reason:

If this question can be reworded to fit the rules in the help center, please edit the question.

4 Answers

up vote 6 down vote accepted

I solved the problem by running:

xrandr --addmode VGA1 1366x768

I also added new modes to the change resolution drop down by using,

xrandr --newmode "mode line"

Where mode line replaces the supported resolutions. You can find the supported resolutions by running:

xrandr

Currently, it's working all right.

share|improve this answer
add comment

I had this problem, and I seem to have fixed it with the following.

I found this thread from the ubuntuforums.org useful.

1) If you need 1280x1024 (what I needed):

xrandr --newmode "1280x1024_60_new" 138.54 1280 1368 1504 1728 1024 1025 1028 1069 -HSync +Vsync

xrandr --addmode VGA-0 1280x1024_60_new

2) If you need 1440x900 (that's what the guy used, should work)

xrandr --newmode "1440x900_60.00"  106.47  1440 1520 1672 1904  900 901 904 932  -HSync +Vsync

xrandr --addmode HDMI1 1440x900_60.00

The only problem with this is that the resolution disappears after a restart and a message says could not apply the stored configuration for monitors. You can write a startup script though.

share|improve this answer
add comment

Applications > Monitors enter image description here

Click the drop-dowm menu named Resolution and choose one that suits

Then click Apply

Then click Close.

share|improve this answer
    
I did earlier and the maximum resolution I could get was 1024x768 (4:3). However after I ran xrandr --addmode VGA1 1360x728 in the terminal a new resolution is added to the drop down. But when I set it, the side bar get all mixed up. (Please see the screenshot in the question) –  Dananjaya Apr 28 '11 at 8:37
add comment

To run at startup add the xrandr commands in /etc/gdm/Init/Default just before "initctl ..." https://wiki.ubuntu.com/X/Config/Resolution

For my Dell 2711 I ran these two lines:

xrandr --newmode "1920x1200_60.00" 193.25 1920 2056 2256 2592 1200 1203 1209 1245 -hsync +vsync
xrandr --addmode HDMI1 "1920x1200_60.00"

(Not sure why it thinks I'm connected to HDMI, when it is actually connected to Display Port via DVI converter, perhaps that's why it's confused about the resolution options.)

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.