Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have all of them locked to the panel, but they keep moving around upon logging out and back in. So, for example, sometimes the Indicator Applet Session is farthest to the right, but sometimes the Clock/Calendar is, and occasionally the Notification Area is. This is a small issue, but annoying.

share|improve this question
    
The only time that I saw that was when using different monitors, or a remote login (in other words : changing the resolution, and then the layout of the panels). Is it your case ? –  Little Jawa Jul 29 '10 at 13:54
    
Do you use gnome or kde? –  txwikinger Jul 29 '10 at 13:59
    
IIRC the Indicator Applet is GNOME-only. –  lfaraone Jul 29 '10 at 14:05
    
I'm using GNOME 2.30.2 with Ubuntu 10.04. I'd guess it has something to do with the fact that I've added Epiphany and gmail-notify to my list of start-up apps, but I'm not sure. –  eugenemarshall Jul 29 '10 at 14:13

2 Answers 2

up vote 4 down vote accepted

There is no real solution except to wait for bug #44082 to be fixed. However, there is a (very hackish) workaround. Put your panel applets where you want them, then run gconftool-2 --dump /apps/panel panel_backup.xml. When the applets get messed up, run

 gconftool-2 --load panel_backup.xml
 killall gnome-panel
share|improve this answer
    
wouldn't gnome-panel --replace & be more apt? –  lfaraone Jul 29 '10 at 14:16
    
No, because if you do it this way, you can close the terminal afterwards. –  snostorm Jul 29 '10 at 14:36
3  
I've noticed that just running killall gnome-panel often solves this problem for me without the gconftool-2 bit. –  Jim Jul 29 '10 at 15:08
    
I usually just Ctrl + Alt + Backspace to restart X a bit excessive but eh. –  Marco Ceppi Jul 29 '10 at 16:31
    
AFAIK, Ctrl + Alt + Backspace does not work in recent Ubuntu releases. –  snostorm Jul 30 '10 at 17:27

I use a simpler and more user friendly solution, IMO, than dumping to XML and restoring (which didn't always work for me, btw).

So, the answer to life, universe and everything is (not 42):
1. Install "Lockdown Editor" using Ubuntu Software Center (or whatever you prefer)
2. Launch "Lockdown Editor" under "System->Administration"
3. Under "Panel" enable "Lock down the panels"

Whenever I want to make changes to the panels I disable the setting, make the changes and enable it again. Worked like a charm for me so I hope it helps others too.

Cheers!

share|improve this answer
    
IIRC, there is a "Lockdown all panels" option in Ubuntu Tweak. I wonder if this option would accomplish the same thing? –  eugenemarshall Aug 6 '10 at 10:43
    
It might. I never used Ubuntu Tweak but I'd say it's a pretty good bet it does just the same. You can also do it with gconf-editor or gconftool-2 directly. –  Li Lo Aug 6 '10 at 16:23
    
Yep, the "Lockdown all panels" option in Ubuntu Tweak does the same thing. –  Li Lo Aug 14 '10 at 15:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.