Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My libboost package is broken. I don't know how to fix it. I tried:

sudo apt-get autoremove

and it was the result:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 libboost-chrono1.54-dev : Depends: libboost1.54-dev (= 1.54.0-2ubuntu3) but it is not installed
 libboost-date-time1.54-dev : Depends: libboost1.54-dev (= 1.54.0-2ubuntu3) but it is not installed
 libboost-exception1.54-dev : Depends: libboost1.54-dev (= 1.54.0-2ubuntu3) but it is not installed
 libboost-filesystem1.54-dev : Depends: libboost1.54-dev (= 1.54.0-2ubuntu3) but it is not installed
 libboost-graph-parallel1.54-dev : Depends: libboost1.54-dev (= 1.54.0-2ubuntu3) but it is not installed
 libboost-graph1.54-dev : Depends: libboost1.54-dev (= 1.54.0-2ubuntu3) but it is not installed
 libboost-iostreams1.54-dev : Depends: libboost1.54-dev (= 1.54.0-2ubuntu3) but it is not installed
 libboost-locale1.54-dev : Depends: libboost1.54-dev (= 1.54.0-2ubuntu3) but it is not installed
 libboost-log1.54-dev : Depends: libboost1.54-dev (= 1.54.0-2ubuntu3) but it is not installed
 libboost-math1.54-dev : Depends: libboost1.54-dev (= 1.54.0-2ubuntu3) but it is not installed
 libboost-mpi1.54-dev : Depends: libboost1.54-dev (= 1.54.0-2ubuntu3) but it is not installed
 libboost-program-options1.54-dev : Depends: libboost1.54-dev (= 1.54.0-2ubuntu3) but it is not installed
 libboost-python1.54-dev : Depends: libboost1.54-dev (= 1.54.0-2ubuntu3) but it is not installed
 libboost-random1.54-dev : Depends: libboost1.54-dev (= 1.54.0-2ubuntu3) but it is not installed
 libboost-regex1.54-dev : Depends: libboost1.54-dev (= 1.54.0-2ubuntu3) but it is not installed
 libboost-serialization1.54-dev : Depends: libboost1.54-dev (= 1.54.0-2ubuntu3) but it is not installed
 libboost-signals1.54-dev : Depends: libboost1.54-dev (= 1.54.0-2ubuntu3) but it is not installed
 libboost-system1.54-dev : Depends: libboost1.54-dev (= 1.54.0-2ubuntu3) but it is not installed
 libboost-test1.54-dev : Depends: libboost1.54-dev (= 1.54.0-2ubuntu3) but it is not installed
 libboost-thread1.54-dev : Depends: libboost1.54-dev (= 1.54.0-2ubuntu3) but it is not installed
 libboost-timer1.54-dev : Depends: libboost1.54-dev (= 1.54.0-2ubuntu3) but it is not installed
 libboost-wave1.54-dev : Depends: libboost1.54-dev (= 1.54.0-2ubuntu3) but it is not installed
 libboost1.54-all-dev : Depends: libboost1.54-dev but it is not installed
E: Unmet dependencies. Try using -f.

Then I tried:

sudo apt-get install -f libboost1.54-dev

and it was the result:

Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libboost-atomic1.53.0 libboost-context1.53.0 libboost-graph1.53.0 libboost-locale1.53.0 libboost-math1.53.0 libboost-python1.53.0
  libboost-random1.53.0 libboost-signals1.53.0 libboost-test1.53.0 libboost-timer1.53.0 libboost-wave1.53.0 libboost1.53-tools-dev
Use 'apt-get autoremove' to remove them.
Suggested packages:
  libboost1.54-doc libboost-coroutine.54-dev libboost-log.54-dev xsltproc doxygen default-jdk fop
The following NEW packages will be installed:
  libboost1.54-dev
0 upgraded, 1 newly installed, 0 to remove and 14 not upgraded.
24 not fully installed or removed.
Need to get 0 B/10.3 MB of archives.
After this operation, 101 MB of additional disk space will be used.
(Reading database ... 320270 files and directories currently installed.)
Unpacking libboost1.54-dev (from .../libboost1.54-dev_1.54.0-2ubuntu3_amd64.deb) ...
dpkg: error processing /var/cache/apt/archives/libboost1.54-dev_1.54.0-2ubuntu3_amd64.deb (--unpack):
 trying to overwrite '/usr/bin/quickbook', which is also in package libboost1.53-tools-dev 1.53.0-6+exp3ubuntu8
No apport report written because MaxReports is reached already
                                                              dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/libboost1.54-dev_1.54.0-2ubuntu3_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

And this is the result of sudo apt-get check:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 libboost-chrono1.54-dev : Depends: libboost1.54-dev (= 1.54.0-2ubuntu3) but it is not installed
 libboost-date-time1.54-dev : Depends: libboost1.54-dev (= 1.54.0-2ubuntu3) but it is not installed
 libboost-exception1.54-dev : Depends: libboost1.54-dev (= 1.54.0-2ubuntu3) but it is not installed
 libboost-filesystem1.54-dev : Depends: libboost1.54-dev (= 1.54.0-2ubuntu3) but it is not installed
 libboost-graph-parallel1.54-dev : Depends: libboost1.54-dev (= 1.54.0-2ubuntu3) but it is not installed
 libboost-graph1.54-dev : Depends: libboost1.54-dev (= 1.54.0-2ubuntu3) but it is not installed
 libboost-iostreams1.54-dev : Depends: libboost1.54-dev (= 1.54.0-2ubuntu3) but it is not installed
 libboost-locale1.54-dev : Depends: libboost1.54-dev (= 1.54.0-2ubuntu3) but it is not installed
 libboost-log1.54-dev : Depends: libboost1.54-dev (= 1.54.0-2ubuntu3) but it is not installed
 libboost-math1.54-dev : Depends: libboost1.54-dev (= 1.54.0-2ubuntu3) but it is not installed
 libboost-mpi1.54-dev : Depends: libboost1.54-dev (= 1.54.0-2ubuntu3) but it is not installed
 libboost-program-options1.54-dev : Depends: libboost1.54-dev (= 1.54.0-2ubuntu3) but it is not installed
 libboost-python1.54-dev : Depends: libboost1.54-dev (= 1.54.0-2ubuntu3) but it is not installed
 libboost-random1.54-dev : Depends: libboost1.54-dev (= 1.54.0-2ubuntu3) but it is not installed
 libboost-regex1.54-dev : Depends: libboost1.54-dev (= 1.54.0-2ubuntu3) but it is not installed
 libboost-serialization1.54-dev : Depends: libboost1.54-dev (= 1.54.0-2ubuntu3) but it is not installed
 libboost-signals1.54-dev : Depends: libboost1.54-dev (= 1.54.0-2ubuntu3) but it is not installed
 libboost-system1.54-dev : Depends: libboost1.54-dev (= 1.54.0-2ubuntu3) but it is not installed
 libboost-test1.54-dev : Depends: libboost1.54-dev (= 1.54.0-2ubuntu3) but it is not installed
 libboost-thread1.54-dev : Depends: libboost1.54-dev (= 1.54.0-2ubuntu3) but it is not installed
 libboost-timer1.54-dev : Depends: libboost1.54-dev (= 1.54.0-2ubuntu3) but it is not installed
 libboost-wave1.54-dev : Depends: libboost1.54-dev (= 1.54.0-2ubuntu3) but it is not installed
 libboost1.54-all-dev : Depends: libboost1.54-dev but it is not installed
E: Unmet dependencies. Try using -f.

and the result of

apt-cache policy libboost1.54-all-dev libboost-wave1.54-dev libboost-python1.54-dev

is:

libboost1.54-all-dev:
  Installed: 1.54.0-2ubuntu3
  Candidate: 1.54.0-2ubuntu3
  Version table:
 *** 1.54.0-2ubuntu3 0
        500 http://ir.archive.ubuntu.com/ubuntu/ saucy/universe amd64 Packages
        100 /var/lib/dpkg/status
libboost-wave1.54-dev:
  Installed: 1.54.0-2ubuntu3
  Candidate: 1.54.0-2ubuntu3
  Version table:
 *** 1.54.0-2ubuntu3 0
        500 http://ir.archive.ubuntu.com/ubuntu/ saucy/universe amd64 Packages
        100 /var/lib/dpkg/status
libboost-python1.54-dev:
  Installed: 1.54.0-2ubuntu3
  Candidate: 1.54.0-2ubuntu3
  Version table:
 *** 1.54.0-2ubuntu3 0
        500 http://ir.archive.ubuntu.com/ubuntu/ saucy/universe amd64 Packages
        100 /var/lib/dpkg/status

What should I do to repair libboost package?

share|improve this question
    
Search the package you need to install, in packages.ubuntu.com matching to your System version. Then try to install the package appropriate to your system version. –  user224082 Nov 9 '13 at 17:57
    
What is the output of apt-cache policy libboost1.54-all-dev libboost-wave1.54-dev libboost-python1.54-dev? –  Braiam Nov 9 '13 at 19:14
    
@Braiam add its output to question. –  Bardia Heydari Nov 10 '13 at 11:08
    
Did you remove libboost1.53-tools-dev as said in my answer? –  Braiam Nov 10 '13 at 13:06
    
I tired apt-get purge -f and the result was same as apt-get autoremove –  Bardia Heydari Nov 10 '13 at 13:37

2 Answers 2

up vote 2 down vote accepted

I have just encountered the same problem and libboost1.54-dev just would not overwrite libboost1.53-dev. My goal was to install libboost1.54-all-dev, but all the other packages depended on libboost1.54-dev and that would not install.

So I went to packages.ubuntu.com and searched for libboost1.54-dev for saucy (link) and downloaded the file.

Once the deb file was in my computer I had to install it while forcing it to overwrite with the following line:

sudo dpkg -i --force-overwrite libboost1.54-dev_1.54.0-2ubuntu3_amd64.deb

after that just doing

sudo apt-get update && sudo apt-get install -f && sudo apt-get autoremove

solved the issue.

Hope this helps.

share|improve this answer

Remove libboost1.53-tools-dev then try again.

sudo apt-get purge -f libboost1.53-tools-dev
sudo apt-get install -f

If no error appears here, continue,

sudo apt-get autoremove

otherwise edit your question and add the result of sudo apt-get check.

share|improve this answer
    
again the same error. –  Bardia Heydari Nov 9 '13 at 19:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.