Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have one the of the new Haswell NUCs that just came out - D34010WYK.

https://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=23089&lang=eng&OSVersion=OS%20Independent&DownloadType=Documentation),

I tried to load ubuntu minimal 13.10 x64 from the mini.iso and it cannot properly detect a network during install - my guess is a driver issue. Tried 12.04 lts and it doesnt even see the NIC at all. Is there anything I could do to get one of the current versions to see the network properly?

I did try the latest trusty nightly desktop and it did install without issue. Is there a minimal version of that?

Thanks Ernie

share|improve this question

1 Answer 1

The ethernet configuration for 13.10 never worked for me during the installation. The wireless card does work (if you installed one). If you are able to reach a terminal after installation, you can setup the NIC yourself by editing

sudo nano /etc/network/interfaces

Add to the end,

auto em1
iface em1 inet dhcp

Save, then start the new NIC with

sudo ifup em1

Use ifconfig to confirm.

On Ubuntu 12.04, it should be called eth0 instead of em1. If you are not sure, use

sudo lshw -C network

and you can see what your NICs are called.

Specs: Intel NUC DC3217IYE

Works on: Ubuntu Server 12.04.2 Ubuntu Server 13.10 Ubuntu Minimal 13.10

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.