Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm having trouble getting a cheap LCD 18.5 inch monitor to work properly with Ubuntu 10.04.1. The brand is "Great Wall". It's supposed to have resolution 1366x768, but I can only set it as 1360x768.

I have Ubuntu installed on an external hard drive, and for what it's worth, at work I have a nicer 18.5 inch monitor, HP brand, also 1366 x 768, and it works perfectly when I boot there.

I have tried using cvt, but it gives me this:

$ cvt 1366 768
# 1368x768 59.88 Hz (CVT) hsync: 47.79 kHz; pclk: 85.25 MHz
Modeline "1368x768_60.00"   85.25  1368 1440 1576 1784  768 771 781 798 -hsync +vsync

I managed to add this 1368 x 768 mode to my xorg.conf, that I generated using some command I can't remember now (sorry!), but it looked just as bad as 1360 x 768, so I undid the change.

I can live with it for watching video, but any extended OpenOffice session makes me want to poke my eyes out :)

I'm using Intel graphics: 00:02.0 VGA compatible controller: Intel Corporation 82915G/GV/910GL Integrated Graphics Controller (rev 04)

Any suggestions? Can I get the EDID out of the HP monitor and try to override it for the monitor at home? (and cross my fingers)

EDIT: I have added the xorg-edgers PPA, and it didn't make any difference. Here is my Xorg.0.log in case it helps: http://clippy.cz.cc/index.php?show=124

EDIT2: I got the modeline for 1366 x 768 on the HP monitor at work. Going to try it at home and see what happens. This is what I got from the Xorg.0.log when booting the computer with my external HD with Ubuntu 10.04:

Modeline "1366x768"x0.0   85.50  1366 1435 1578 1790  768 771 781 798 -hsync +vsync (47.8 kHz)

EDIT3: Tried the modeline above, and it gave similar results to modelines for 1360 and 1368. But then I noticed something, so see below for the answer to my own question :)

share|improve this question
    
did you try running ubuntu off livecd/liveusb and check if you still have the bad display issue ? –  koushik Sep 6 '10 at 12:54
    
I just tried it, same situation. –  UrkoM Sep 6 '10 at 13:41

1 Answer 1

up vote 0 down vote accepted

Well, this will teach me to actually spend appropriate money on monitors...

This "Elcheapo" Great Wall monitor (obviously made in China) just "says" that it can do 1366x768... What it actually does is simply accept higher resolutions, and downscale everything to 1280x768.

I noticed in one of the info screens of the monitor setup menus (the ones you get by pressing the buttons on the edge of the monitor itself) that, no matter which modeline I set, it always reported the resolution as 1280x768, though I didn't get that resolution offered by the System->Preferences->Monitors application.

So I used cvt to generate a modeline for that resolution:

$ cvt 1280 768
# 1280x768 59.87 Hz (CVT) hsync: 47.78 kHz; pclk: 79.50 MHz
Modeline "1280x768_60.00"   79.50  1280 1344 1472 1664  768 771 781 798 -hsync +vsync
$ xrandr --newmode "1280x768_60.00"   79.50  1280 1344 1472 1664  768 771 781 798 -hsync +vsync
$ xrandr --addmode VGA1 "1280x768_60.00"

Then I finally could choose 1280x768 resolution in the System->Preferences->Monitors application.

And lo and behold! Fantastically clear, crisp text!!! I've lost 86 horizontal pixels over what was advertised, but it's well worth it.

Someday I might try this screen with Windows, but with no computer running that at home, it will be a while... But I doubt Windows can make pixel columns magically appear in an LCD screen! :)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.