Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just got new dell inspiron3537 with Ubuntu 12.04 LTS (no windows O/S). It got some wireless (hard block) yesterday. So, this morning, I ran the software update all the security update.

After that I can't see "Wireless" in system setting. So, I updated all the software update and looked thru several web site and found sudo lshw -c network command. I tried and found the result below.

  *-network
       description: Ethernet interface
       product: RTL8101E/RTL8102E PCI Express Fast Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:01:00.0
       logical name: eth0
       version: 07
       serial: 74:86:7a:40:5d:48
       size: 100Mbit/s
       capacity: 100Mbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full ip=192.168.1.10 latency=0 link=yes multicast=yes port=MII speed=100Mbit/s
       resources: irq:60 ioport:4000(size=256) memory:c0700000-c0700fff memory:c0400000-c0403fff

  *-network UNCLAIMED
       description: Network controller
       product: QCA9565 / AR9565 Wireless Network Adapter
       vendor: Qualcomm Atheros
       physical id: 0
       bus info: pci@0000:02:00.0
       version: 01
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: latency=0
       resources: memory:c0600000-c067ffff memory:9fb00000-9fb0ffff

Please suggest what I should do to fix it.

share|improve this question
1  
Are you sure you haven't switched wifi off with a keystroke? laptops have a key set to turn wifi off for when you are on planes. On mine it is f12. worth checking first anyway. –  comrademike Nov 9 '13 at 11:49
    
Welcome to Ask Ubuntu! Please use the contact us link at the bottom of this page to ask for your unregistered account and your new registered account to be merged. Thanks. –  Eric Carvalho Nov 12 '13 at 10:31
1  
This solved my problem ubuntuforums.org/showthread.php?t=2172044 –  tropikalista Nov 25 '13 at 15:26

1 Answer 1

I had the same problem. The solution is here http://ubuntuforums.org/showthread.php?t=2103062 (Compaq has the same adapter). I followed the instructions and now wi-fi works properly.

...we install the prerequitites needed to compile:

sudo apt-get install linux-headers-generic build-essential

Now we download the package, extract it and install it:

wget http://www.orbit-lab.org/kernel/compat-wireless-3-stable/v3.6/compat-wireless-3.6.6-1-snpc.tar.bz2 tar xvf compat* cd compat-wireless-3.6.6-1-snpc sudo su ./scripts/driver-select ath9k make make install modprobe ath9k exit

share|improve this answer
    
While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. –  Braiam Dec 2 '13 at 13:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.