Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This is my first post here, and I'm pretty new to Ubuntu/Linux. I currently have no other OS except for Ubuntu 13.10. (I used to have Windows 7 until i got a new Tera-byte hard drive).

My current PC build, if any of this helps:

CPU: Intel i5 quad-core
Graphics: NVIDIA GeForce GTX 650
Motherboard: MSi Z77 A-G41
OS: Ubuntu 13.10

So I recently installed Ubuntu 13.10 and put Steam on it, and I'm seeing that my games run a lot slower than they did when I had Windows 7. I figured it was a graphics problem, so I checked System Settings → Details → Overview. It says in "Graphics" that I have "Gallium 0.4 on NVE7" (don't really know what that is). Does this mean that Ubuntu is not using my graphics card?

In System Settings → Software & Updates → Additional Drivers, it clearly shows like this:

NVIDIA Corporation: GK107 [GeForce GTX 650] -This device is using an alternative driver

(And then it shows a list of drivers that I can switch back and forth to)

So this is a bit confusing. In Software and Updates, it clearly shows that I have my NVIDIA card installed, and that I have a driver selected for it. But in System Settings, it shows I have some Gallium 0.4 thing.

I had done a bit of research, and ended up typing command:

lspci|grep VGA

in the Terminal. It showed this in response:

VGA compatible controller: NVIDIA Corporation GK107 [GeForce GTX 650] (rev a1)

The Terminal seems to recognize my graphics card.

What it looks like to me, is that I don't have the proper driver, and I might be using my CPU's integrated graphics. When I switch around which driver I am using in that list, it still does not see my card in System Settings. Some of the drivers in the list give me some sort of OpenGL error when I try to run a game.

It might just be that my games are running slow because the game developers have not optimized it for Ubuntu that well. However, that still doesn't take away from the fact that System Settings is not showing my NVIDIA card.

TL;DR Version:

How do I know if my video card is being recognized/used? If my video card is not being used, what is the best way fix that?

Please make your answers easy to understand. I do not mind wordy responses, as long as I can follow what you're saying.

Any help would be greatly appreciated! Thanks.

share|improve this question
  • It seems you are running free driver where Steam recommend NVIDIA proprietary driver. You can confirm using: glxinfo or more precisely:

    glxinfo | grep OpenGL
  • Myself I have bad experience with installing NVIDIA proprietary driver from Ubuntu repository. so I would prefer downloading it from NVIDIA website. Check your OS architecture 32bit or 64bit using System Monitor or by just running one of these commands:

    file /bin/ls    
    uname -a
  • Drop shell using Ctrl+Alt+F6 , login

    cd to_directory_where_driver
    sudo su
    chmod +x driver_filename
    service lightdm stop

Read very well the installing messages as the default is not always what you want.

You should keep that driver installation file because it needed in case you want to revert or repair the installation.

share|improve this answer

Try going to 'SOFTWARE & UPDATES' check 'Additional Drivers' Tab, and install the newest Driver listed there. then reboot.


To install the latest NVidia drivers look here:



I found these articles useful, and this:

General Documentation

Steam help:



I personally do not use Steam in Unity, I found it quite system resource heavy. So I installed an alternative light weight GUI, such as Gnome, LUbuntu, XUbuntu,etc, and run Steam from there, I found it greatly improved performance.


share|improve this answer

Steps to install drivers NVIDIA GEFORCE GTX 650 in Ubuntu.

Motherboard: GIGABYTE GA970DS3P / Processor: AMD FX-4130 Quad-Core 3.8GHz Socket AM3+

  1. Download the drivers file from NVIDIA website

  2. Open a terminal (Ctrl+Alt+F1) and run:

    sudo apt-get install build-essential
    sudo service lightdm stop
    sudo init 3

    Change to the downloaded driver directory and run:

    sudo sh
    sudo service lightdm start 
    sudo reboot

If the Ubuntu boot displays an error message at startup follow these steps to resolve a conflict of drivers:

  1. Run:

    sudo apt-add-repository ppa:ubuntu-x-swat/x-updates
    sudo apt-get update
    sudo apt-get dist-upgrade
    sudo reboot
  2. After the reboot open a terminal (Ctrl+Alt+F1) and run:

    sudo service lightdm stop
    sudo init 3

    Change to the downloaded driver directory and run:

    sudo sh
    sudo service lightdm start 
    sudo reboot
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.