Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm fairly new to Linux and I'm currently running Linux Mint 13 (based on Ubuntu 12.04). I'm trying to install Bumblebee with preferably the latest stable Nvidia 319 drivers on my Asus R505CB (this specs, but with GT740M instead of the GT635M).

I've been trying a lot of things the past two days without succes. With Nouveau only the integrated graphics are working and when I install any version of the nVidia driver (both via the nVidia website and PPA's) Cinnamon can't start and I get this error when I start NVIDIA X Server Settings:

You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run nvidia-xconfig as root), and restart the X server.

Now, trying to install Bumblebee once again I see I apparently overlooked this line on this wiki:

If on 12.04.3, replace linux-headers-generic with linux-headers-generic-lts-raring.

How do I do this? I have currently installed the 3.12 Linux kernel (had 3.2, which was default).

1) I guess I have to use this 3.8 kernel instead of the 3.12 version to make bumblebee work?

2) When I tried installing it, it installed these packages:

linux-headers-generic-lts-raring

linux-image-3.8.0-33-generic

linux-image-generic-lts-raring

But it doesn't place a .bin file in the /boot folder so when i run sudo update-grub it wouldn't detect this 3.8 kernel and I'm still using the 3.2 version with which I can't get the Bumblebee daemon started.

What to do?

I'm sure I forgot to say something... :p

Thanks in advance,

share|improve this question
    
what was the output of uname -r.If you install linux 3.8 kernel, it must be in /usr/src folder. –  Avinash Raj Nov 9 '13 at 0:18
    
is that 3.8 kernal is in /usr/src folder. –  Avinash Raj Nov 9 '13 at 11:03
    
"uname -r" gives output: "3.2.0-56-generic" and in the folder "/usr/src" are these folders: "linux-headers-3.8.0-33", "linux-headers-3.8.0-33-generic" and "nvidia-319-319.49". –  user212822 Nov 9 '13 at 11:05
    
When I run "sudo update-grub" I get this:<br/>"<br/>Searching for GRUB installation directory ... found: /boot/grub<br/> Searching for default file ... found: /boot/grub/default<br/> Testing for an existing GRUB menu.lst file ... found: /boot/grub/menu.lst<br/> Searching for splash image ... none found, skipping ...<br/> Found kernel: /boot/vmlinuz-3.2.0-56-generic<br/> Found kernel: /boot/memtest86+.bin<br/> Updating /boot/grub/menu.lst ... done<br/> " –  user212822 Nov 9 '13 at 11:05
    
askubuntu.com/questions/119080/… it would help you to update kernal. –  Avinash Raj Nov 9 '13 at 11:17
show 1 more comment

1 Answer

Run the below command to update your kernal,

sudo apt-get install linux-generic

After installation,reboot your pc.

share|improve this answer
    
Thanks, but that is just the 3.2 version of the Linux Kernel... Right? –  user212822 Nov 10 '13 at 16:39
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.