Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I created a LiveUSB of Ubuntu 12.04.3 LTS using Pendrive Linux.

  • Created a separate 30GB partition using Windows 8 Disk Management
  • Disabled Secure Boot (Didn't find an option to disable EFI boot)
  • Disabled Fast Startup

The laptop starts the GRUB menu shows up but it doesn't go beyond that no matter what option i choose. After choosing any option the screen goes blank but the power is still on i can see the power light.

My laptop is:

processor- Intel i5 4200U
Video Card- 2GBnVidia 740M

The GRUB menu I see :


share|improve this question
Did you use a 64 bit version, with a release 12.04.2 or 12.04.3? Those are the only ones which work with UEFI. Any idea what video chip you have? editing the grub "Try" command to add "nomodeset" might help. – ubfan1 Nov 8 '13 at 17:52
ok i ddint get what you mean by 'try' command and 'nomodeset'.Please be clear this is my 1st installation of a Linux iam a complete amateur. – Vulcan Nov 9 '13 at 3:47
Is this dual video or just nVidia? Nomodeset works for nVidia, but if booting with Intel video you need different settings. At grub menu press e, for edit, scroll to linux line and replace quiet splash with nomodeset. The quiet splash setting hide the boot process so you will see a lot of activity. – oldfred Nov 9 '13 at 4:59
Yosh ! Thanks replacing quiet splash with nomodeset worked.Any reason for why this happened? – Vulcan Nov 9 '13 at 5:27
There are occasional kinks with odd video setups, particularly under EFI. I expect the Ubuntu and Linux kernel developers are aware of the problem and working on it, but I've not been following their efforts very closely. – Rod Smith Nov 9 '13 at 19:11
up vote 0 down vote accepted

Do you use a 64 bit version, with 12.04.2/12.04.3 release? They are the only ones which work with UEFI. Any idea of what video chip you have? Editing the grub "Try" command to add "nomodeset" might help.

Thanks to ubfan1 for the answer.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.