Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

using Ubuntu 13.10 on a Lenovo E135, I've installed the Haskell package and the yesod helper package via Ubuntu Software Center. Installation was success. But if I want to create an Yesod project with "yesod init" and "yesod devel" as provided in the Quick start guid at yesod web site, this failed. Error message told something about "cabal install failed during configuration step on library xy... ExitCode 1" which caused some dependencies to be unresolved but needed for the yesod project to compile.

I've tried also to install Haskell via Ubuntu Software center and yesod via cabal with the same result (but different libraries indicated in the error Message).

Thanks for help

Hans

share|improve this question
add comment

1 Answer

Tried some things by myself. The result:

It worked when applying this setup:

Haskell installation with:

sudo apt-get install haskell-platform

yesod installation with:

sudo apt-get install yesod

Cabal update.

And then continuing as provided in the quick start docu of yesod, yesod init etc etc.

Need to verify this, but at the moment it works, yesod test project compiled and runned nicely.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.