Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

100% cpu usage when streaming flash video with Chrome, but firefox use less than 50% of my cpu usage.

what causing this? also any workaround to fix it? thank you.

share|improve this question

marked as duplicate by Eric Carvalho, Radu Rădeanu, Alaa Ali, guntbert, Seth Sep 4 '13 at 1:33

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
+1, chrome frequently hogs memory on my machine –  user Apr 28 '11 at 12:55
    
Get use to it... and the problem lies with flash, not Chrome. –  TheX Sep 7 '12 at 15:22
    
confirmed that dupe answer helps a LOT –  user128334 Sep 10 '13 at 14:23

4 Answers 4

Try using Lightspark, an alternative to Adobe's flash:

sudo add-apt-repository ppa:sparkers/daily
sudo apt-get update
sudo apt-get install lightspark browser-plugin-lightspark

And then:

sudo apt-get install lightspark browser-plugin-lightspark

Source: http://www.unixmen.com/lightspark-a-good-alternative-to-adobe-flash-player-ppa-ubuntu-fedora-rpm/

share|improve this answer
    
i get the exact same spikes w lightspark + no swf –  user128334 Sep 9 '13 at 23:43

Found the issue, it has to do with the standalone version of Flash and Chrome's integrated Flash conflicting with one another, trying to load both at the same time

Do the following:

  • In Chrome's address bar, type "about:plugins" (no space between colon and plugins)

  • This will bring up a list of plugins

  • Look for the Flash plugin and when you find it, it may say 2 or more files. For example mine said 3 as shown here: Flash (3 files) - Version: 11,4,402,265

  • Over to the far right is a DETAILS link. Click on it. This will bring up details for each file/version you have installed

  • Look at the "Location:" of each version – some may be the integrated Chrome version (…Application Data\Google\Chrome etc) and the other is the standalone Adobe (formerly Macromedia) version which is in the …Windows\system32\Macromed\Flash etc directory.

  • You don't want the integrated Chrome version(s). Click on "Disable" just under the Location(s) of the Chrome version to disable it (and it will become grayed out)

  • Ensure that the standalone Adobe version is still enabled – if it is disabled (grayed out) click the ‘Enable’ link just under its Location to enable it) then close the Plugins tab

You're good to go. This should get rid of Flash constantly using 100% CPU for Flash videos.

share|improve this answer
    
i tried both. didn't help me –  user128334 Sep 10 '13 at 12:28

I think that Chrome is not the problem, the unique problem is Flash. Now I'm watching a video in window mode and CPU is nearly at 90%, but if I put it to fullscreen mode it decrease to 50%. Seems to be a problem with scaling video or something similar.

share|improve this answer

It seems to be the Chrome's plugin "sandboxing". In Chrome forums they recommend to clear cache, but that works in some cases...

You can try Chromium and install Adobe Flash separately (Chrome includes a customized version of Flash).

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.