Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using HP Pavilion 15 -no11tu which has been awarded the status of Enabled for Ubuntu.

When Ubuntu was shipped with my hp laptop,Everything worked fine including WiFi,webcam and Bluetooth.

Some days ago I formatted my System and reinstalled Ubuntu 12.04.3 LTS which I downloaded for Ubuntu website. But Instead of connecting my system to internet and after doing all update and upgrade Ubuntu didn't detected my system WiFi and Bluetooth.

HP does not provide driver support for Linux.

My Configuuration::

htcoders@ubuntu:~$ sudo ifconfig

eth0      Link encap:Ethernet  HWaddr a4:5d:36:7b:f2:d7  
          inet addr:172.16.232.178  Bcast:172.16.232.255  Mask:255.255.255.0
          inet6 addr: fe80::a65d:36ff:fe7b:f2d7/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:888333 errors:0 dropped:112 overruns:0 frame:0
          TX packets:715296 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:1156686828 (1.1 GB)  TX bytes:51009168 (51.0 MB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:12787 errors:0 dropped:0 overruns:0 frame:0
          TX packets:12787 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:800669 (800.6 KB)  TX bytes:800669 (800.6 KB)

htcoders@ubuntu:~$ lspci

00:00.0 Host bridge: Intel Corporation Haswell-ULT DRAM Controller (rev 09)
00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 09)
00:03.0 Audio device: Intel Corporation Device 0a0c (rev 09)
00:14.0 USB controller: Intel Corporation Lynx Point-LP USB xHCI HC (rev 04)
00:16.0 Communication controller: Intel Corporation Lynx Point-LP HECI #0 (rev 04)
00:1b.0 Audio device: Intel Corporation Lynx Point-LP HD Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation Lynx Point-LP PCI Express Root Port 1 (rev e4)
00:1c.1 PCI bridge: Intel Corporation Lynx Point-LP PCI Express Root Port 2 (rev e4)
00:1c.2 PCI bridge: Intel Corporation Lynx Point-LP PCI Express Root Port 3 (rev e4)
00:1c.3 PCI bridge: Intel Corporation Lynx Point-LP PCI Express Root Port 4 (rev e4)
00:1d.0 USB controller: Intel Corporation Lynx Point-LP USB EHCI #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation Lynx Point-LP LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation Lynx Point-LP SATA Controller 1 [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation Lynx Point-LP SMBus Controller (rev 04)
02:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. Device 5227 (rev 01)
08:00.0 Network controller: MEDIATEK Corp. Device 7630
09:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 08)

Please Help.

Thanks

share|improve this question
add comment

1 Answer

Wifi :

Driver can be installed as running followings :

sudo apt-get install collectd-core collectd-dev collectd-dbg collectd-utils

Then Install the network Manager for the wifi connectons - Wicd

(You can run with Network Manager. But for channel selection and many other features can be done with Wicd)

sudo apt-get install wicd-gtk wicd wicd-daemon wicd-curses wicd-cli

Bluetooth :

Drivers for the bluetooth devices can be installed with :

sudo apt-get install bluez bluez-alsa bluez-audio bluez-btsco bluez-compat bluez-cups bluez-dbg bluez-gstreamer bluez-hcidump bluez-pcmcia-support bluez-tools bluez-utils python-bluez bluewho indicator-bluetooth libbluetooth-dev  libgnome-bluetooth11 libbluetooth3
share|improve this answer
    
still not working!!(Not even on Ububtu 14.04 lts) It is reported as BUG to launch pad answers.launchpad.net/ubuntu/+question/243203 answers.launchpad.net/ubuntu/+question/243203 –  Rishabh Upadhyay 2 days ago
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.