Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am a relatively new Ubuntu user and I am having some difficulty mounting my external 2TB HDD. When I first installed Linux my external HDD was working just fine, however, it has stopped working and I have a lot of important files on there that I need.

Before my HDD would automatically mount and no worries. Now, however, it doesn't automatically mount and when I try to manually mount it I keep running into filesystem type errors that I can't seem to get past.

Below are images that depict my step by step process of how I am trying to mount my HDD along with the errors I am receiving. If anybody has any idea what I am doing wrong or how to correct the issue I would greatly appreciate it.

Step 1) Ensure the computer recognizes my external HDD.

pj@PJ:~$ dmesg

...

[ 5790.367910] scsi 7:0:0:0: Direct-Access WD My Passport 0748 1022 PQ: 0 ANSI: 6

[ 5790.368278] scsi 7:0:0:1: Enclosure WD SES Device 1022 PQ: 0 ANSI: 6

[ 5790.370122] sd 7:0:0:0: Attached scsi generic sg2 type 0

[ 5790.370310] ses 7:0:0:1: Attached Enclosure device

[ 5790.370462] ses 7:0:0:1: Attached scsi generic sg3 type 13

[ 5792.971601] sd 7:0:0:0: [sdb] 3906963456 512-byte logical blocks: (2.00 TB/1.81 TiB)

[ 5792.972148] sd 7:0:0:0: [sdb] Write Protect is off

[ 5792.972162] sd 7:0:0:0: [sdb] Mode Sense: 47 00 10 08

[ 5792.972591] sd 7:0:0:0: [sdb] No Caching mode page found

[ 5792.972605] sd 7:0:0:0: [sdb] Assuming drive cache: write through

[ 5792.975235] sd 7:0:0:0: [sdb] No Caching mode page found

[ 5792.975249] sd 7:0:0:0: [sdb] Assuming drive cache: write through

[ 5792.987504] sdb: sdb1

[ 5792.988900] sd 7:0:0:0: [sdb] No Caching mode page found

[ 5792.988911] sd 7:0:0:0: [sdb] Assuming drive cache: write through

[ 5792.988920] sd 7:0:0:0: [sdb] Attached SCSI disk

Step 2) Check if it mounted properly (it does not)

pj@PJ:~$ df -ah

Filesystem Size Used Avail Use% Mounted on

/dev/sda1 682G 3.9G 644G 1% /

proc 0 0 0 - /proc

sysfs 0 0 0 - /sys

none 0 0 0 - /sys/fs/fuse/connections

none 0 0 0 - /sys/kernel/debug

none 0 0 0 - /sys/kernel/security

udev 2.9G 4.0K 2.9G 1% /dev

devpts 0 0 0 - /dev/pts

tmpfs 1.2G 928K 1.2G 1% /run

none 5.0M 0 5.0M 0% /run/lock

none 2.9G 156K 2.9G 1% /run/shm

gvfs-fuse-daemon 0 0 0 - /home/pj/.gvfs

Step 3) Try mounting manually using NTFS and VFAT (both as SDB and SDB1)

pj@PJ:~$ sudo mount /dev/sdb /media/Passport/

NTFS signature is missing.

Failed to mount '/dev/sdb': Invalid argument

The device '/dev/sdb' doesn't seem to have a valid NTFS.

Maybe the wrong device is used? Or the whole disk instead of a

partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around?

pj@PJ:~$ sudo mount /dev/sdb1 /media/Passport/

NTFS signature is missing.

Failed to mount '/dev/sdb1': Invalid argument

The device '/dev/sdb1' doesn't seem to have a valid NTFS.

Maybe the wrong device is used? Or the whole disk instead of a

partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around?

pj@PJ:~$ sudo mount -t ntfs /dev/sdb /media/Passport/

NTFS signature is missing.

Failed to mount '/dev/sdb': Invalid argument

The device '/dev/sdb' doesn't seem to have a valid NTFS.

Maybe the wrong device is used? Or the whole disk instead of a

partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around?

pj@PJ:~$ sudo mount -t vfat /dev/sdb /media/Passport/

mount: wrong fs type, bad option, bad superblock on /dev/sdb,

   missing codepage or helper program, or other error

   In some cases useful info is found in syslog - try

   dmesg | tail  or so

pj@PJ:~$ sudo mount -t ntfs /dev/sdb1 /media/Passport/

NTFS signature is missing.

Failed to mount '/dev/sdb1': Invalid argument

The device '/dev/sdb1' doesn't seem to have a valid NTFS.

Maybe the wrong device is used? Or the whole disk instead of a

partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around?

pj@PJ:~$ sudo mount -t vfat /dev/sdb1 /media/Passport/

mount: wrong fs type, bad option, bad superblock on /dev/sdb1,

   missing codepage or helper program, or other error

   In some cases useful info is found in syslog - try

   dmesg | tail  or so
share|improve this question
add comment

1 Answer 1

How to Mount a NTFS File System in Linux

Download ntfs 3g from here using wget command from terminal

Download ntfs 3g

tar -xvf ntfs-3g_ntfsprogs-2013.1.13.tgz

./configure

 make

 make install

sudo mount -t ntfs-3g /dev/sdb1 /mnt/ntfs HDD

fstab Entry For Permanent mounting after restart

sudo vim /etc/fstab

/dev/sda1 /mnt/ntfs HDD ntfs-3g defaults 0 0

Enter the fstab entry at last

share|improve this answer
    
How exactly does this work? What is it doing when I run these commands? –  Snuggie Nov 9 '13 at 3:16
    
So I installed the ntfs-3g program and I am still getting the same errors as before. It says "NTFS signature missing" –  Snuggie Nov 9 '13 at 15:07
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.