Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I logged out of my normal desktop and selected LX games from the dropdown list and logged back in. This led me to a black screen and now I can't see the login screen in order to change back to my normal desktop. On startup the machine boots normally, the lubuntu splash screen shows up, then it goes to a black screen with nothing on it - not even a mouse cursor. I can bring up a terminal using ctrl+alt+F2.
Is there a way via terminal to change my desktop environment back to its previous state?
Or alternatively, is there a file I can edit where my preferred desktop is stored? (The machine is dual-booted so I can access the Lubuntu files from LXLE which is installed on a second partition). The machine in question is a Toshiba A200 laptop.
UPDATE: I was unable to find a satisfactory way around this so have re-installed the OS. Has anyone else been adventurous enough to select the lx games desktop and if so did they have any problems?

share|improve this question

2 Answers 2

Press the combination CTRL-ALT-F1 login with your root password type top to see the current active programs running then type killall lxsession

share|improve this answer
1  
Please add more details to your answer, proper formatting will also improve legibility. –  LiveWireBT Nov 16 '13 at 8:13

I also selected LX Games session and could not see any UI after that. This is what worked for me: I edited the file /etc/lightdm/lightdm.conf

[SeatDefaults] autologin-guest=true --> I set this var to true autologin-user=user_name autologin-user-timeout=0 autologin-session=lightdm-autologin greeter-session=lightdm-gtk-greeter user-session=Lubuntu

After this change I restarted my computer.

I don't know if this is the correct way to solve it, but at least I was able to logout and select back the Lubuntu session, and reset the autologin-guest var to false again. This link was also helpful for me: https://wiki.ubuntu.com/LightDM

Note: I activated the autologin option when I installed Lubuntu.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.