Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Hello everyone and thank you for taking a look at this topic!

I'm currently trying out Ubuntu 13.10 but I keep hitting a wall when it comes to installing a driver.

I've tried:

sudo apt-get install nvidia-current

This resulted in a un-bootable system. The screen just stayed black and the cursor displayed as an 'X'. After that I did had to re-install Ubuntu.

The computer I'm using is an Acer-Aspire-V3 with a build in Nvidia geforce GT 630M and also with a Intel HD graphics chip-set (not sure if chip-set is the right word here). "lspci | grep VGA" output:

pascal@pascal-Aspire-V3-571G:~$ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
01:00.0 VGA compatible controller: NVIDIA Corporation GF108M [GeForce GT 630M] (rev a1)

I've searched a bit here and there and found out that it would be wise to mention that this laptop is using (or so I think) Nvidia Optimus, not sure if it will add anything to the subject but at least I'll mention it just to be sure.

Now to the questions:

Q1 How is this caused and how can I fix it?

Q2 What additional information could I provide to help you help me?

share|improve this question
possible duplicate of How well do laptops with Nvidia Optimus work?. It is caused because of dual GPU which are not supported by linux nvidia driver. – Web-E Nov 7 '13 at 17:47
up vote 1 down vote accepted

First of all I'm no pro at ubuntu but do know how to fix your problem

sudo apt-get install bumblebee bumblebee-nvidia

This installs bumblebee and the nvidia drivers.

bumblebee configures your nvidia graphics card correctly to use it. Your desktop will be rendered with intels graphics but you can run programs with nvidia by using optirun programname you can also install primus

sudo apt-get install primus

This installs primus, it helps you run programs with the nvidia graphics in a locked fps count, I think its for vsync really. you can run programs in the terminal writing primusrun programname

share|improve this answer
Thank you for your response! I've tryed your solution and wanted you to know that Ubuntu didn't crash on reboot. So I'm guessing that everything works fine but I've got nothing to test it with for now because of the forced re-installation. I'm going to download some games and post the results. thank you again for you help! – Pascal Nov 8 '13 at 8:11
Hello again, I've tried both opti- and primusrun and so far so good! I've played some games that I've tryed before and it works so much better now. So thank you again! – Pascal Nov 8 '13 at 16:41

On my laptop I have Intel i7 processor (with hardware-dissabled intel grafics) and nVidia GTX 770m ...

I'had the same problem after installing nvidia 331 driver:

sudo add-apt-repository ppa:xorg-edgers/ppa
sudo apt-get update
sudo apt-get install nvidia-331

I fix the problem by completely removing bumblebee driver:

sudo apt-get --purge remove bumblebee
sudo reboot

This is an example that linux is very flexable and one problem can have many different sollutions... or non at all :P

share|improve this answer

Hei you may find this useful. It also includes bumblebee-ui. Here you go:
Can´t use Nvidia GPU?

share|improve this answer

First of all to get your bootable screen you need to remove NVidia That is done by,press 'ctrl+alt+F1' to get the command shell. Then type
$sudo apt-get purge nvidia*
$sudo apt-get autoremove
$sudo reboot
Then try some other method. It worked for me but still trying to figure out how to install the driver.

share|improve this answer
what other methods? please add relative links or at least one working method. – Registered User Feb 19 '14 at 6:32
Just try this method. Press 'ctrl+alt+F1' when you end up at black screen and try the commands. It worked for me. I think it will work for you also. Other methods means the method for installing nvidia driver. I am going to try bumblebee then I will let you know. – rkmrajan Feb 19 '14 at 8:47

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.