Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm having problem with Webcam and fed up with this search in Google for answers.

So I've connected webcam to my computer having Ubuntu 13.10, and i tried to run luvcview program to simply see the output, that didn't worked gives me output

ERROR: Requested frame format MJPG is not available and no fallback format was found.

. Then i used lsusb gives me output

Bus 007 Device 003: ID 0ac8:301b Z-Star Microelectronics Corp. ZC0301 Webcam

So using this link Downloaded driver for my webcam. when i tried to install i.e.., using make in this directory i downloaded it gives me error videodev.h is not available, So I used ln -s libv4l1-videodev.h videodev.h and again tried to make, here i got error which i'm not familiar with. Can Any one solve this problem

**************************************************************************
* Building Video4Linux2 driver for                                       *
*          ZC0301 and ZC0301P Image Processor and Control Chip...        *
* Official Linux 2.6.19 is the minimum version for this driver.          *
* Read the documentation "zc0301.txt" for more informations.             *
* Type "make help" for a list of available targets.                      *
**************************************************************************

make -C /lib/modules/`uname -r`/build M=/home/srinivas/zc0301-1.10 modules
make[1]: Entering directory `/usr/src/linux-headers-3.2.0-55-generic-pae'
  CC [M]  /home/srinivas/zc0301-1.10/zc0301_core.o
In file included from /usr/lib/gcc/i686-linux-gnu/4.6/include/stdint.h:5:0,
                 from /usr/local/include/libv4l1-videodev.h:13,
                 from /home/srinivas/zc0301-1.10/zc0301_sensor.h:26,
                 from /home/srinivas/zc0301-1.10/zc0301.h:43,
                 from /home/srinivas/zc0301-1.10/zc0301_core.c:46:
/usr/lib/gcc/i686-linux-gnu/4.6/include/stdint-gcc.h:86:26: error: conflicting types for ‘uintptr_t’
include/linux/types.h:44:24: note: previous declaration of ‘uintptr_t’ was here
/home/srinivas/zc0301-1.10/zc0301_core.c: In function ‘zc0301_vidioc_querycap’:
/home/srinivas/zc0301-1.10/zc0301_core.c:1024:41: error: ‘struct device’ has no member named ‘bus_id’
/home/srinivas/zc0301-1.10/zc0301_core.c: In function ‘zc0301_ioctl’:
/home/srinivas/zc0301-1.10/zc0301_core.c:1914:2: error: implicit declaration of function ‘v4l_print_ioctl’ [-Werror=implicit-function-declaration]
/home/srinivas/zc0301-1.10/zc0301_core.c: At top level:
/home/srinivas/zc0301-1.10/zc0301_core.c:1928:2: error: unknown field ‘ioctl’ specified in initializer
/home/srinivas/zc0301-1.10/zc0301_core.c:1928:2: warning: initialization from incompatible pointer type [enabled by default]
/home/srinivas/zc0301-1.10/zc0301_core.c:1928:2: warning: (near initialization for ‘zc0301_fops.fsync’) [enabled by default]
/home/srinivas/zc0301-1.10/zc0301_core.c:1929:18: error: ‘v4l_compat_ioctl32’ undeclared here (not in a function)
/home/srinivas/zc0301-1.10/zc0301_core.c: In function ‘zc0301_usb_probe’:
/home/srinivas/zc0301-1.10/zc0301_core.c:1987:13: error: ‘struct video_device’ has no member named ‘owner’
/home/srinivas/zc0301-1.10/zc0301_core.c:1988:13: error: ‘struct video_device’ has no member named ‘type’
/home/srinivas/zc0301-1.10/zc0301_core.c:1989:13: error: ‘struct video_device’ has no member named ‘hardware’
/home/srinivas/zc0301-1.10/zc0301_core.c:1990:20: warning: assignment from incompatible pointer type [enabled by default]
cc1: some warnings being treated as errors
make[2]: *** [/home/srinivas/zc0301-1.10/zc0301_core.o] Error 1
make[1]: *** [_module_/home/srinivas/zc0301-1.10] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-3.2.0-55-generic-pae'
make: *** [modules] Error 2

Any one with similar problem solved this? Or any alternative? Thanks in advance

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.