Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I already added Hungarian as a language, but in the keyboard menu settings I don't see any other keyboard available to add or set. I don't want to change the default system language, just the keyboard, and I don't want to change the layout manually key by key.

I'm using 12.04.3 LTS.

share|improve this question

2 Answers 2

Using the GUI you can do it like this:

  1. Open the Keyboard app (accessible through the Dash)
  2. Click the Layout Settings link in the lower left
  3. Click the + button on the lower left (below the list of existing layouts)
  4. Search for the Hungarion layout you wish and Click Add
  5. Close the Keyboard app (a keyboard button will show up in the top menu bar that lets you select a layout)

If you wish to remove the US keyboard use the - button in the layout list.

share|improve this answer

Just run the following command in terminal:

gsettings set org.gnome.libgnomekbd.keyboard layouts "['hu', 'us']"

If you want only Hungarian keyboard layout, use:

gsettings set org.gnome.libgnomekbd.keyboard layouts "['hu']"
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.