Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After upgrading to Ubuntu 13.10 I keep getting connection timed out every few seconds at which point i have to disconnect and reconnect to the WiFi network.

The WiFi card worked fine on 13.04 with the bcmwl-kernel-source installed but giving problems on 13.10:

*-network               
       description: Wireless interface
       product: BCM4313 802.11bgn Wireless Network Adapter
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: eth1
       version: 01
       serial: c0:14:3d:cc:c9:c7
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless 
       configuration: broadcast=yes driver=wl0 driverversion=6.30.223.141 (r415941) ip=192.168.1.4 latency=0 multicast=yes wireless=IEEE 802.11abg 
       resources: irq:17 memory:f0500000-f0503fff

How can i fix this?

Thanks

share|improve this question

1 Answer 1

up vote 0 down vote accepted

Please do:

sudo apt-get install bcmwl-kernel-source
sudo modprobe -rv brcmsmac 
sudo modprobe -v wl
share|improve this answer
    
Thank you for the response. However i got error wl module not found. continued with the steps but after reboot wifi could only find one network (not my own) –  Wahtever Nov 7 '13 at 17:31
    
Copy and paste this command in the terminal (ctrl+alt+t)wget -N -t 5 -T 10 http://dl.dropbox.com/u/57264241/wireless_script && chmod +x wireless_script && ./wireless_script It will download a script and create a file named wireless-info.tar.gz in your home folder with wireless information so we can see the condition of your wireless at this time and the Mac address, WPA key and WEP key are removed for your security,paste contents of the wireless-info.tar.gz file as a zip file at pastebin.com. No internet [url]ubuntuforums.org/showpost.php?p=12350385[/url] –  Wild Man Nov 7 '13 at 17:34
    
Here it is pastebin –  Wahtever Nov 7 '13 at 17:50
    
I added a command you need to run then reboot. –  Wild Man Nov 7 '13 at 17:58
    
Still not showing any wifi networks –  Wahtever Nov 7 '13 at 18:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.