Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to start hbase with the following command:

hadoop@user-HP-dx2480-MT-NA125PA:/usr/local/hadoop/hbase$ bin/start-hbase.sh

and the startup fails with the following errror:

error are localhost: starting zookeeper, logging to /usr/local/hadoop/hbase/bin/../logs/hbase-hadoop-zookeeper-user-HP-dx2480-MT-NA125PA.out localhost: java.net.BindException: Address already in use localhost: at sun.nio.ch.Net.bind(Native Method) localhost: at sun.nio.ch.ServerSocketChannelImpl.bind(ServerSocketChannelImpl.java:137) localhost: at sun.nio.ch.ServerSocketAdaptor.bind(ServerSocketAdaptor.java:77) localhost: at sun.nio.ch.ServerSocketAdaptor.bind(ServerSocketAdaptor.java:70) localhost: at org.apache.zookeeper.server.NIOServerCnxn$Factory.(NIOServerCnxn.java:122) localhost: at org.apache.zookeeper.server.ZooKeeperServerMain.runFromConfig(ZooKeeperServerMain.java:106) localhost: at org.apache.hadoop.hbase.zookeeper.HQuorumPeer.runZKServer(HQuorumPeer.java:85) localhost: at org.apache.hadoop.hbase.zookeeper.HQuorumPeer.main(HQuorumPeer.java:70)

What is the solution for this? Can anyone tel me? What is AddressBindingException??

share|improve this question

1 Answer 1

up vote 0 down vote accepted

It looks like your zookeeper process is already running. Or (much less likely), something else is already listening on port 2181 or 2888. Did you install a separate zookeeper package and start it?

If so, you'll need to tell HBase not to start zookeeper automatically. Edit the conf/hbase-env.sh file and add the line:

export HBASE_MANAGES_ZK=false

On the other hand, if you want HBase to start zookeeper automatically, then change that setting to "true", make sure any current zookeeper process is stopped and try again.

FYI, if you run into more problems, subscribe to the HBase user mailing list at user-subscribe@hbase.apache.org and we can help you further there.

share|improve this answer
    
yes it worked ya.. Thanks –  priyaudupi Apr 28 '11 at 6:16
    
@piryaudupi if you are satisfied with the answer, please accept it. This will increase your 'acceptance rate' –  Chakra Apr 28 '11 at 7:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.