Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Today I have tried to update the package lists and I have encountered strange error

$ sudo apt-get update
...
Ign http://archive.ubuntu.com saucy-security/universe Translation-en_US
Ign http://archive.ubuntu.com saucy-proposed/main Translation-en_US
Ign http://archive.ubuntu.com saucy-proposed/restricted Translation-en_US
Ign http://archive.ubuntu.com saucy-proposed/universe Translation-en_US
Fetched 496 kB in 38s (13.0 kB/s)
E: Unable to change to (unreachable)// - chdir (2: No such file or directory)

What should I change now ? Something in /etc/apt/sources.list ?

share|improve this question
    
Please see this, bugs.launchpad.net/ubuntu/+source/apt/+bug/771780 –  Masroor Nov 7 '13 at 1:35
    
Can you help me on what should I do in this situation ? –  Patryk Nov 7 '13 at 1:49
    
Is that Saucy installed or Beta version? –  Braiam Nov 7 '13 at 1:52
    
Does not look like I can of much assistance. The only advice we find there is something in the line of not detaching your drive while updating a system. Did you do something like that? If the answer is yes, do you want to try reattaching the drive and running update again? Good luck. –  Masroor Nov 7 '13 at 1:54
    
@Braiam That's Saucy installed. –  Patryk Nov 7 '13 at 12:08

3 Answers 3

I got this error message every time I ran sudo apt-get update with an encrypted home directory, while I was in my home directory.

If I cd'd to / first, the error went away.

(Ubuntu Server 13.10)

share|improve this answer
    
I found my self in a removable disk that I had ejected. Changing into my home folder got me going again. This put me on the right path (literally). –  Aeyoun Feb 11 at 23:32
    
This worked for me on 14.04 Server –  Dennis Aug 15 at 13:12
up vote 1 down vote accepted

Reinstalling libapt-pkg helped .

share|improve this answer

I had this happen today. It was because my current directory was mounted with sshfs. I don't know if it would occur with any FUSE file system or just sshfs, but the answer was to just get out of that directory. That is:

cd
sudo apt-get update
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.