Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I am using a partition created from Wubi, and this is only because Windows is needed for activities like gaming and watching movies on certain websites that require the Silverlight plugin. All of the partitions I have created in the past have worked fine. This new install, however, has a problem.

I formated a month or so back to allow more space. Back then, I only created a partition that allowed for a few gigs of space. I deleted the partition in windows and gave myself the 30gb partition. This is because I planned to work from my Ubuntu partition entirely except for the above-mentioned things. It worked fine for a week or so.

Then, for some reason, the Ubuntu loading screen (the purple one with the four or five red dots that slowly light up) went wrong. Instead of coming to this screen from start-up in my native resolution of 1440x900 and having the dots all light up before the operating system presented the login screen, the system waited a while at the screen with the blinking underscore, then quickly flashed green, presented the purple Ubuntu screen in a low resolution, allowed time for only 2 or 3 dots to light up, and the instantly took me to the login screen.

This was originally only a problem with start-up. However, it is now a problem with shutdown too, and I fear it might be detrimental to my system the way it works. Whenever I shut down, the same purple Ubuntu screen comes up in low resolution. There is no green flash here. It just appears after my programs are assumed to have closed. The dots begin to light up, and after only a couple of the dots light up as opposed to all of them, the system suddenly just shuts down.

Lately, it has also had some other problems. These happen every once in a while as in every three or four days. When I go to shut down, the purple Ubuntu screen will appear but without the dots yet still in a low resolution mode. There will be some text over the logo as if it is a terminal outputting information from the system about closing programs, killing the system, and so on. Sometimes this text appears for a short while before the shutdown.

Other times, my system has actually been stuck on this screen; requiring a hard shutdown. In fact, when I installed Kubuntu Desktop Environment a few weeks back (This was after the problem, so it's not KDE), I shut down my computer and went to bed without confirming it had shut down. When I woke up, my computer had literally sat all night at the Kubuntu logo display screen; having failed to shut down.

Does anyone know what the problem is? I don't think it's my graphics card or processor or anything, even though both of them currently have their problems. Windows loads fine. The Ubuntu partition works fine when I am working in it. There are no problems elsewhere. I do not remember installing any software that would do this. The last big modification to my system around the time this started were simple changes of my desktop wallpaper.

share|improve this question

closed as too localized by Luis Alvarado Mar 14 '13 at 17:09

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

2 Answers 2

Did you install the Nvidia proprietary driver? At my maschine (nvidea grahpics card) i also have low resolution startup screen.

But i don't think that there is a fix for this. Only Nvidia can improve it's binary drivers.

share|improve this answer

I was using an NVidia 6200 with the proprietary driver for a while, and while Plymouth (the boot splash) looked cruddy, it worked normally (though the green flash thing sounds familiar). I am now using an ATI Radeon HD 4650 with the open-source driver.

I have, however, experienced a similar problem under similar circumstances. I replaced a Seagate Barracuda 320GB with a WD Caviar Blue 640GB, and reinstalled from scratch. On the new drive, I experienced much the same symptoms: blinking cursor for a long time, then a brief glimpse of Plymouth (sometimes no Plymouth at all), then login screen. This was well after changing video cards; the hard drive was the only change I made at that time.

After some investigation, I discovered that time spent watching the blinking cursor was actually a delay in finding the hard drive. Linux hadn't even started yet. I went into the BIOS and removed unnecessary drives from the boot sequence, and now there's a lot less time spent looking at a blinking cursor (though still more than there used to be) and Plymouth displays normally. I can't explain why the problem shows up with one drive and not the other, though. It might have something to do with TLER or partition alignment, but those are just guesses.

As for shutdown, I think it's normal for not all the dots to light up. As far as I can tell, the dots are just a spinner, and don't reflect actual progress. That said, I have problems with shutdown as well; in my case, I just see messages, no splash at all. I have not had the system fail to power off, however. This started at the same time as the startup problems, but I have yet to find a solution.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.