Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Ubuntu is not detecting LAN sometimes.And 95 % of time it doesnot detect wifi.The network option says wifi are not in range even though they are

It usually happens when the ubuntu stays idle for long time.

But there are cases when I start my laptop and LAN is not detected.

It usually gets fixed when I reboot

I tried to do both of these things: software and updates->Additional Drivers->Mark and unmark wireless card.

But none of them worked

Edit: lspci -nn | grep -e 0200 -e 0280 gives:

04:00.0 Network controller [0280]: Broadcom Corporation BCM43224 802.11a/b/g/n [14e4:4353] (rev 01)
09:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 03)
share|improve this question
    
We need to know what wireless card you are using and what driver is installed. Please edit your question and add output from the two terminal commands: lspci | grep 802 and lsmod | grep 802 –  Nullet Nov 6 '13 at 10:38
    
Please edit your question to add the results of: lspci -nn | grep -e 0200 -e 0280 –  chili555 Nov 6 '13 at 14:02
    
Updated whatever you asked for.Please reply –  Atul Nov 7 '13 at 8:38
    
come on dude!!! –  Atul Nov 16 '13 at 7:24
add comment

1 Answer 1

You can open up a terminal CTRL+ALT+T and install the broadcom-kernel-source.

sudo apt-get install bcmwl-kernel-source

and then reboot.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.